CVE-2020-8130 OS Command Injection in Rake
Attackers can execute arbitrary OS commands via filenames starting with a pipe character in the Ruby Rake library.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-8130?
CVE-2020-8130 is a medium-severity command injection vulnerability in Canonical Ubuntu Linux, published on 24 Feb 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
There is an OS command injection vulnerability in Ruby Rake < 12.3.3 in Rake::FileList when supplying a filename that begins with the pipe character `|`.
Weakness: CWE-78
Which versions are affected by CVE-2020-8130?
2 open source packages ship an affected version, including rake. It affects 5 products.
| Package | Affected | Fixed in |
|---|---|---|
rake RubyGems | All versions | 12.3.3 |
rake RubyGems | All versions | 12.3.3 |
Linux distribution packages (1)
rubygem-rake SUSE:Linux Enterprise Module for Containers 12 | All versions | 10.3.2-9.7.1 |
Products include Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Opensuse Leap, Ruby-Lang Rake.
How do I fix CVE-2020-8130?
Upgrade rake to 12.3.3 or later.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2020-8130 being exploited?
There is no known exploitation of CVE-2020-8130 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2020-8130, DLA-2120-1, GHSA-jppv-gw3r-w3q8, MGASA-2020-0121, SUSE-SU-2022:3212-1, UBUNTU-CVE-2020-8130 and 1 more.