# CVE-2020-8130: OS Command Injection in Rake

> Attackers can execute arbitrary OS commands via filenames starting with a pipe character in the Ruby Rake library.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-8130, DLA-2120-1, GHSA-jppv-gw3r-w3q8, MGASA-2020-0121, SUSE-SU-2022:3212-1, UBUNTU-CVE-2020-8130, USN-4295-1

## What is CVE-2020-8130?

CVE-2020-8130 is a medium-severity command injection vulnerability in Canonical Ubuntu Linux, published on 24 Feb 2020. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

There is an OS command injection vulnerability in Ruby Rake < 12.3.3 in Rake::FileList when supplying a filename that begins with the pipe character `|`.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2020-8130?

2 open source packages ship an affected version, including rake. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rake` | RubyGems | All versions | 12.3.3 |
| `rake` | RubyGems | All versions | 12.3.3 |
| `rubygem-rake` | SUSE:Linux Enterprise Module for Containers 12 | All versions | 10.3.2-9.7.1 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Fedoraproject Fedora, Opensuse Leap, Ruby-Lang Rake.

## How do I fix CVE-2020-8130?

Upgrade rake to 12.3.3 or later.

## Is CVE-2020-8130 being exploited?

There is no known exploitation of CVE-2020-8130 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8130 and fix it if it is affected.

What it is: CVE-2020-8130 is a medium-severity command injection vulnerability in Canonical Ubuntu Linux, published on 24 Feb 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-8130 in the wild and no public exploit code.

Affected packages and fixed versions:
- rake (RubyGems): affected all versions; fixed in 12.3.3
- rake (RubyGems): affected all versions; fixed in 12.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8130/ (Markdown: https://insights.sbomify.com/CVE-2020-8130/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8130
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8130
- OSV: https://osv.dev/vulnerability/CVE-2020-8130

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8130/
Summaries are generated and may contain mistakes; the official description above is the record.
