# CVE-2020-8134: Server-side request forgery in Ghost CMS

> An attacker can exploit Ghost CMS to scan local or external networks and interact with internal systems via server-side request forgery.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-ghost-2020-8134, GHSA-q4h8-7qff-gh6c

## What is CVE-2020-8134?

CVE-2020-8134 is a high-severity server-side request forgery vulnerability in Ghost, published on 20 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Server-side request forgery (SSRF) vulnerability in Ghost CMS < 3.10.0 allows an attacker to scan local or external network or otherwise interact with internal systems.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2020-8134?

3 open source packages ship an affected version, including ghost. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | All versions | 3.10.0 |
| `ghost` | npm | All versions | 3.10.0 |
| `ghost` | npm | All versions | 3.10.0 |

Products: Ghost Ghost.

## How do I fix CVE-2020-8134?

Upgrade ghost to 3.10.0 or later.

## Is CVE-2020-8134 being exploited?

There is no known exploitation of CVE-2020-8134 in the wild and no public exploit code.

## Other vulnerabilities in Ghost

- [CVE-2022-27139](https://insights.sbomify.com/CVE-2022-27139/): Arbitrary file upload in Ghost (critical 9.8)
- [CVE-2022-28397](https://insights.sbomify.com/CVE-2022-28397/): Arbitrary file upload in Ghost (critical 9.8)
- [CVE-2022-41654](https://insights.sbomify.com/CVE-2022-41654/): ghost vulnerable to unauthorized newsletter modification via improper access controls (critical 9.6)
- [CVE-2026-26980](https://insights.sbomify.com/CVE-2026-26980/): Ghost has a SQL Injection in its Content API (critical 9.4)
- [CVE-2024-34451](https://insights.sbomify.com/CVE-2024-34451/): Security feature bypass in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8134 and fix it if it is affected.

What it is: CVE-2020-8134 is a high-severity server-side request forgery vulnerability in Ghost, published on 20 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-8134 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected all versions; fixed in 3.10.0
- ghost (npm): affected all versions; fixed in 3.10.0
- ghost (npm): affected all versions; fixed in 3.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8134/ (Markdown: https://insights.sbomify.com/CVE-2020-8134/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8134
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8134
- OSV: https://osv.dev/vulnerability/CVE-2020-8134

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8134/
Summaries are generated and may contain mistakes; the official description above is the record.
