{"answers":{"affected":"2 open source packages ship an affected version, including @uppy/companion. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-8135 in the wild and no public exploit code.","fix":"Upgrade @uppy/companion to 1.9.3 or later.","what":"CVE-2020-8135 is a critical server-side request forgery vulnerability in uppy, published on 20 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-8135 and fix it if it is affected.\n\nWhat it is: CVE-2020-8135 is a critical server-side request forgery vulnerability in uppy, published on 20 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-8135 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @uppy/companion (npm): affected all versions; fixed in 1.9.3\n- @uppy/companion (npm): affected all versions; fixed in 1.9.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-8135/ (Markdown: https://insights.sbomify.com/CVE-2020-8135/index.md)","id":"CVE-2020-8135","markdown":"https://insights.sbomify.com/CVE-2020-8135/index.md","name":"CVE-2020-8135","record":{"aliases":["GHSA-mm7r-265w-jv6f"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript file uploader","requires_auth":"none","summary":"An attacker can exploit this SSRF vulnerability in the Uppy library to scan internal networks or interact with internal systems.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"uppy","vendor":"uppy"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"The uppy npm package \u003c 1.9.3 is vulnerable to a Server-Side Request Forgery (SSRF) vulnerability, which allows an attacker to scan local or external network or otherwise interact with internal systems.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Server-Side Request Forgery in @uppy/companion","id":"CVE-2020-8135","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2020"},"n_packages":2,"n_references":1,"next":{"headline":"Uncontrolled Resource Consumption in fastify-multipart","id":"CVE-2020-8136"},"packages":[{"ecosystem":"npm","fixed":["1.9.3"],"introduced":["0"],"last_affected":[],"package":"@uppy/companion","purl":null,"source":"GHSA-mm7r-265w-jv6f"},{"ecosystem":"npm","fixed":["1.9.3"],"introduced":["0"],"last_affected":[],"package":"@uppy/companion","purl":"pkg:npm/%40uppy/companion","source":"GHSA-mm7r-265w-jv6f"}],"prev":{"headline":"Server-side request forgery in Ghost CMS","id":"CVE-2020-8134"},"products":["uppy"],"published":"2020-03-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"An attacker can exploit this SSRF vulnerability in the Uppy library to scan internal networks or interact with internal systems.","url":"https://insights.sbomify.com/CVE-2020-8135/"}