{"answers":{"affected":"2 open source packages ship an affected version, including blamer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-8137 in the wild and no public exploit code.","fix":"Upgrade blamer to 1.0.1 or later.","what":"CVE-2020-8137 is a critical code injection vulnerability in blamer, published on 20 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-8137 and fix it if it is affected.\n\nWhat it is: CVE-2020-8137 is a critical code injection vulnerability in blamer, published on 20 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-8137 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- blamer (npm): affected all versions; fixed in 1.0.1\n- blamer (npm): affected all versions; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-8137/ (Markdown: https://insights.sbomify.com/CVE-2020-8137/index.md)","id":"CVE-2020-8137","markdown":"https://insights.sbomify.com/CVE-2020-8137/index.md","name":"CVE-2020-8137","record":{"aliases":["GHSA-7vm7-j8p7-h346"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"npm blamer library","requires_auth":"none","summary":"Attackers can execute arbitrary code via controlled input in the blamer library, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"blamer","vendor":"blamer_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Code injection vulnerability in blamer 1.0.0 and earlier may result in remote code execution when the input can be controlled by an attacker.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Code injection in blamer","id":"CVE-2020-8137","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2020"},"n_packages":2,"n_references":1,"next":{"headline":"Server-side request forgery in Nextcloud Server","id":"CVE-2020-8138"},"packages":[{"ecosystem":"npm","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"blamer","purl":null,"source":"GHSA-7vm7-j8p7-h346"},{"ecosystem":"npm","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"blamer","purl":"pkg:npm/blamer","source":"GHSA-7vm7-j8p7-h346"}],"prev":{"headline":"Uncontrolled Resource Consumption in fastify-multipart","id":"CVE-2020-8136"},"products":["blamer"],"published":"2020-03-20","related":[{"cvss_score":9.8,"headline":"Improper Neutralization of Special Elements used in an OS Command in Blamer","id":"CVE-2019-10807","kev_date_added":null,"published":"2020-03-10"},{"cvss_score":6.5,"headline":"blamer vulnerable to Arbitrary Argument Injection via the blameByFile() API","id":"CVE-2023-26143","kev_date_added":null,"published":"2023-09-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via controlled input in the blamer library, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2020-8137/"}