# CVE-2020-8137: Code injection in blamer

> Attackers can execute arbitrary code via controlled input in the blamer library, requiring an upgrade to mitigate.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-7vm7-j8p7-h346

## What is CVE-2020-8137?

CVE-2020-8137 is a critical code injection vulnerability in blamer, published on 20 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Code injection vulnerability in blamer 1.0.0 and earlier may result in remote code execution when the input can be controlled by an attacker.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2020-8137?

2 open source packages ship an affected version, including blamer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `blamer` | npm | All versions | 1.0.1 |
| `blamer` | npm | All versions | 1.0.1 |

Products: Blamer Project Blamer.

## How do I fix CVE-2020-8137?

Upgrade blamer to 1.0.1 or later.

## Is CVE-2020-8137 being exploited?

There is no known exploitation of CVE-2020-8137 in the wild and no public exploit code.

## Other vulnerabilities in blamer

- [CVE-2019-10807](https://insights.sbomify.com/CVE-2019-10807/): Improper Neutralization of Special Elements used in an OS Command in Blamer (critical 9.8)
- [CVE-2023-26143](https://insights.sbomify.com/CVE-2023-26143/): blamer vulnerable to Arbitrary Argument Injection via the blameByFile() API (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8137 and fix it if it is affected.

What it is: CVE-2020-8137 is a critical code injection vulnerability in blamer, published on 20 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-8137 in the wild and no public exploit code.

Affected packages and fixed versions:
- blamer (npm): affected all versions; fixed in 1.0.1
- blamer (npm): affected all versions; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8137/ (Markdown: https://insights.sbomify.com/CVE-2020-8137/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8137
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8137
- OSV: https://osv.dev/vulnerability/CVE-2020-8137

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8137/
Summaries are generated and may contain mistakes; the official description above is the record.
