# CVE-2020-8141: Improper Control of Generation of Code in doT

> Attackers can execute arbitrary code by controlling templates or Object.prototype in the dot JavaScript library.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** CLSA-2026-1792424782, DEBIAN-CVE-2020-8141, GHSA-297x-8xj4-vcxv

## What is CVE-2020-8141?

CVE-2020-8141 is a high-severity code injection vulnerability in dot, published on 15 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The dot package v1.1.2 uses Function() to compile templates. This can be exploited by the attacker if they can control the given template or if they can control the value set on Object.prototype.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2020-8141?

2 open source packages ship an affected version, including dot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dot` | npm | All versions | 1.1.3 |
| `dot` | npm | All versions | 1.1.3 |

Products: Dot Project Dot.

## How do I fix CVE-2020-8141?

Upgrade dot to 1.1.3 or later.

## Is CVE-2020-8141 being exploited?

There is no known exploitation of CVE-2020-8141 in the wild and no public exploit code.

## Other vulnerabilities in dot

- [CVE-2020-7639](https://insights.sbomify.com/CVE-2020-7639/): eivindfjeldstad-dot contains prototype pollution vulnerability (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8141 and fix it if it is affected.

What it is: CVE-2020-8141 is a high-severity code injection vulnerability in dot, published on 15 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-8141 in the wild and no public exploit code.

Affected packages and fixed versions:
- dot (npm): affected all versions; fixed in 1.1.3
- dot (npm): affected all versions; fixed in 1.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8141/ (Markdown: https://insights.sbomify.com/CVE-2020-8141/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8141
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8141
- OSV: https://osv.dev/vulnerability/CVE-2020-8141

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8141/
Summaries are generated and may contain mistakes; the official description above is the record.
