# CVE-2020-8161: Directory traversal in Rack::Directory app bundled with Rack

> An attacker can exploit a directory traversal flaw in the Rack::Directory app to access unauthorized files and disclose sensitive information.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-8161, DLA-2216-1, GHSA-5f9h-9pjv-v6j7, UBUNTU-CVE-2020-8161

## What is CVE-2020-8161?

CVE-2020-8161 is a high-severity path traversal vulnerability in Canonical Ubuntu Linux, published on 2 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A directory traversal vulnerability exists in rack < 2.2.0 that allows an attacker perform directory traversal vulnerability in the Rack::Directory app that is bundled with Rack which could result in information disclosure.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-548 (Exposure of Information Through Directory Listing)

## Which versions are affected by CVE-2020-8161?

2 open source packages ship an affected version, including rack. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rack` | RubyGems | All versions | 2.1.3 |
| `rack` | RubyGems | All versions | 2.1.3 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Rack Project Rack.

## How do I fix CVE-2020-8161?

Upgrade rack to 2.1.3 or later.

## Is CVE-2020-8161 being exploited?

There is no known exploitation of CVE-2020-8161 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8161 and fix it if it is affected.

What it is: CVE-2020-8161 is a high-severity path traversal vulnerability in Canonical Ubuntu Linux, published on 2 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-8161 in the wild and no public exploit code.

Affected packages and fixed versions:
- rack (RubyGems): affected all versions; fixed in 2.1.3
- rack (RubyGems): affected all versions; fixed in 2.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8161/ (Markdown: https://insights.sbomify.com/CVE-2020-8161/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8161
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8161
- OSV: https://osv.dev/vulnerability/CVE-2020-8161

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8161/
Summaries are generated and may contain mistakes; the official description above is the record.
