# CVE-2020-8162: Circumvention of file size limits in ActiveStorage

> Attackers can bypass upload limits in ActiveStorage S3 adapter by modifying Content-Length, requiring an upgrade to Rails.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-8162, GHSA-m42x-37p3-fv5w, UBUNTU-CVE-2020-8162

## What is CVE-2020-8162?

CVE-2020-8162 is a high-severity vulnerability in Debian Debian Linux, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A client side enforcement of server side security vulnerability exists in rails < 5.2.4.2 and rails < 6.0.3.1 ActiveStorage's S3 adapter that allows the Content-Length of a direct file upload to be modified by an end user bypassing upload limits.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type), CWE-602 (Client-Side Enforcement of Server-Side Security)

## Which versions are affected by CVE-2020-8162?

4 open source packages ship an affected version, including activestorage. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activestorage` | RubyGems | From 5.0.0 | 5.2.4.3 |
| `activestorage` | RubyGems | From 5.0.0 | 5.2.4.3 |
| `activestorage` | RubyGems | From 6.0.0 | 6.0.3.1 |
| `activestorage` | RubyGems | From 6.0.0 | 6.0.3.1 |

Products: Debian Debian Linux, Rubyonrails Rails.

## How do I fix CVE-2020-8162?

Upgrade activestorage to a fixed version for your release line: 5.2.4.3 or 6.0.3.1.

## Is CVE-2020-8162 being exploited?

There is no known exploitation of CVE-2020-8162 in the wild and no public exploit code.

Public exploit code:

- Known security vulnerabilities detected. CVE-2022-21831 Critical severity CVE-2025-24293 Critical severity CVE-2020-8162 High severity CVE-2024-26144 Moderate severity (github_poc): https://github.com/usutani/study-turbolinks-link

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8162 and fix it if it is affected.

What it is: CVE-2020-8162 is a high-severity vulnerability in Debian Debian Linux, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-8162 in the wild and no public exploit code.

Affected packages and fixed versions:
- activestorage (RubyGems): affected from 5.0.0; fixed in 5.2.4.3
- activestorage (RubyGems): affected from 5.0.0; fixed in 5.2.4.3
- activestorage (RubyGems): affected from 6.0.0; fixed in 6.0.3.1
- activestorage (RubyGems): affected from 6.0.0; fixed in 6.0.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8162/ (Markdown: https://insights.sbomify.com/CVE-2020-8162/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8162
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8162
- OSV: https://osv.dev/vulnerability/CVE-2020-8162

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8162/
Summaries are generated and may contain mistakes; the official description above is the record.
