# CVE-2020-8163: Remote code execution via user-provided local names in ActionView

> Attackers can execute arbitrary code by controlling the locals argument in render calls within vulnerable Ruby on Rails versions.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-rails-2020-8163, DEBIAN-CVE-2020-8163, GHSA-cr3x-7m39-c6jq, SUSE-SU-2020:2140-1, UBUNTU-CVE-2020-8163

## What is CVE-2020-8163?

CVE-2020-8163 is a high-severity code injection vulnerability in Debian Debian Linux, published on 2 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The is a code injection vulnerability in versions of Rails prior to 5.0.1 that wouldallow an attacker who controlled the `locals` argument of a `render` call to perform a RCE.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2020-8163?

3 open source packages ship an affected version, including actionview and rails. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionview` | RubyGems | All versions | 4.2.11.3 |
| `actionview` | RubyGems | All versions | 4.2.11.3 |
| `rails` | Bitnami | All versions | 5.0.1 |
| `rubygem-actionview-4_2` | SUSE:OpenStack Cloud 6-LTSS | All versions | 4.2.9-9.9.1 |
| `rubygem-activesupport-4_2` | SUSE:OpenStack Cloud 6-LTSS | All versions | 4.2.9-7.6.1 |
| `rubygem-actionview-4_2` | SUSE:OpenStack Cloud 7 | All versions | 4.2.9-9.9.1 |
| `rubygem-activesupport-4_2` | SUSE:OpenStack Cloud 7 | All versions | 4.2.9-7.6.1 |
| `rubygem-actionview-4_2` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 4.2.9-9.9.1 |
| `rubygem-activesupport-4_2` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 4.2.9-7.6.1 |
| `rubygem-actionview-4_2` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 4.2.9-9.9.1 |
| `rubygem-activesupport-4_2` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 4.2.9-7.6.1 |

Products: Debian Debian Linux, Rubyonrails Rails.

## How do I fix CVE-2020-8163?

Upgrade actionview to 4.2.11.3 or later.

## Is CVE-2020-8163 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-8163 exists.

Public exploit code:

- CVE-2020-8163 - Remote code execution of user-provided local names in Rails (github_poc): https://github.com/lucasamorimca/CVE-2020-8163
- Enviroment and exploit to rce test (github_poc): https://github.com/h4ms1k/CVE-2020-8163
- This is a exploit code for CVE-2020-8163 (github_poc): https://github.com/RedBinaryRabbit/CVE-2020-8163
- Rails 5.0.1 - Remote Code Execution (exploitdb)
- Ruby on Rails <5.0.1 - Remote Code Execution (nuclei): http/cves/2020/CVE-2020-8163.yaml

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8163 and fix it if it is affected.

What it is: CVE-2020-8163 is a high-severity code injection vulnerability in Debian Debian Linux, published on 2 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-8163 exists.

Affected packages and fixed versions:
- actionview (RubyGems): affected all versions; fixed in 4.2.11.3
- actionview (RubyGems): affected all versions; fixed in 4.2.11.3
- rails (Bitnami): affected all versions; fixed in 5.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8163/ (Markdown: https://insights.sbomify.com/CVE-2020-8163/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8163
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8163
- OSV: https://osv.dev/vulnerability/CVE-2020-8163

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8163/
Summaries are generated and may contain mistakes; the official description above is the record.
