CVE-2020-8164 Possible Strong Parameters Bypass in ActionPack
Attackers can exploit untrusted data deserialization in Rails to inadvertently leak information from Strong Parameters.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-8164?
CVE-2020-8164 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A deserialization of untrusted data vulnerability exists in rails < 5.2.4.3, rails < 6.0.3.1 which can allow an attacker to supply information can be inadvertently leaked fromStrong Parameters.
Weakness: CWE-502
Which versions are affected by CVE-2020-8164?
4 open source packages ship an affected version, including actionpack. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
actionpack RubyGems | From 5.0.0 | 5.2.4.3 |
actionpack RubyGems | From 5.0.0 | 5.2.4.3 |
actionpack RubyGems | From 6.0.0 | 6.0.3.1 |
actionpack RubyGems | From 6.0.0 | 6.0.3.1 |
Linux distribution packages (6)
rubygem-actionpack-5_1 SUSE:Linux Enterprise High Availability Extension 15 | All versions | 5.1.4-3.6.1 |
rubygem-actionpack-5_1 SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 5.1.4-3.6.1 |
rubygem-actionpack-5_1 SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 5.1.4-3.6.1 |
rubygem-actionpack-5_1 SUSE:Package Hub 15 SP1 | All versions | 5.1.4-bp151.2.3.1 |
rubygem-actionpack-5_1 openSUSE:Leap 15.1 | All versions | 5.1.4-lp151.4.3.1 |
rubygem-actionpack-5_1 openSUSE:Leap 15.2 | All versions | 5.1.4-lp152.5.3.1 |
Products include Debian Debian Linux, Opensuse Backports Sle, Opensuse Leap, Rubyonrails Rails.
How do I fix CVE-2020-8164?
Upgrade actionpack to a fixed version for your release line: 5.2.4.3 or 6.0.3.1.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2020-8164 being exploited?
There is no known exploitation of CVE-2020-8164 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2020-8164, GHSA-8727-m6gj-mc37, SUSE-SU-2020:2710-1, UBUNTU-CVE-2020-8164, openSUSE-SU-2020:1533-1, openSUSE-SU-2020:1536-1 and 1 more.