# CVE-2020-8164: Possible Strong Parameters Bypass in ActionPack

> Attackers can exploit untrusted data deserialization in Rails to inadvertently leak information from Strong Parameters.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-8164, GHSA-8727-m6gj-mc37, SUSE-SU-2020:2710-1, UBUNTU-CVE-2020-8164, openSUSE-SU-2020:1533-1, openSUSE-SU-2020:1536-1, openSUSE-SU-2020:1575-1

## What is CVE-2020-8164?

CVE-2020-8164 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A deserialization of untrusted data vulnerability exists in rails < 5.2.4.3, rails < 6.0.3.1 which can allow an attacker to supply information can be inadvertently leaked fromStrong Parameters.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2020-8164?

4 open source packages ship an affected version, including actionpack. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | From 5.0.0 | 5.2.4.3 |
| `actionpack` | RubyGems | From 5.0.0 | 5.2.4.3 |
| `actionpack` | RubyGems | From 6.0.0 | 6.0.3.1 |
| `actionpack` | RubyGems | From 6.0.0 | 6.0.3.1 |
| `rubygem-actionpack-5_1` | SUSE:Linux Enterprise High Availability Extension 15 | All versions | 5.1.4-3.6.1 |
| `rubygem-actionpack-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 5.1.4-3.6.1 |
| `rubygem-actionpack-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 5.1.4-3.6.1 |
| `rubygem-actionpack-5_1` | SUSE:Package Hub 15 SP1 | All versions | 5.1.4-bp151.2.3.1 |
| `rubygem-actionpack-5_1` | openSUSE:Leap 15.1 | All versions | 5.1.4-lp151.4.3.1 |
| `rubygem-actionpack-5_1` | openSUSE:Leap 15.2 | All versions | 5.1.4-lp152.5.3.1 |

Products: Debian Debian Linux, Opensuse Backports Sle, Opensuse Leap, Rubyonrails Rails.

## How do I fix CVE-2020-8164?

Upgrade actionpack to a fixed version for your release line: 5.2.4.3 or 6.0.3.1.

## Is CVE-2020-8164 being exploited?

There is no known exploitation of CVE-2020-8164 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8164 and fix it if it is affected.

What it is: CVE-2020-8164 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-8164 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionpack (RubyGems): affected from 5.0.0; fixed in 5.2.4.3
- actionpack (RubyGems): affected from 5.0.0; fixed in 5.2.4.3
- actionpack (RubyGems): affected from 6.0.0; fixed in 6.0.3.1
- actionpack (RubyGems): affected from 6.0.0; fixed in 6.0.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8164/ (Markdown: https://insights.sbomify.com/CVE-2020-8164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8164
- OSV: https://osv.dev/vulnerability/CVE-2020-8164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8164/
Summaries are generated and may contain mistakes; the official description above is the record.
