CVE-2020-8165 ActiveSupport potentially unintended unmarshalling of user-provided objects in MemCacheStore and RedisCacheStore
Attackers can achieve remote code execution by exploiting unsafe deserialization in Rails cache stores when using MemCache or Redis.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-8165?
CVE-2020-8165 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 19 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A deserialization of untrusted data vulnernerability exists in rails < 5.2.4.3, rails < 6.0.3.1 that can allow an attacker to unmarshal user-provided objects in MemCacheStore and RedisCacheStore potentially resulting in an RCE.
Weakness: CWE-502
Which versions are affected by CVE-2020-8165?
4 open source packages ship an affected version, including activesupport. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
activesupport RubyGems | From 5.0.0 | 5.2.4.3 |
activesupport RubyGems | From 5.0.0 | 5.2.4.3 |
activesupport RubyGems | From 6.0.0 | 6.0.3.1 |
activesupport RubyGems | From 6.0.0 | 6.0.3.1 |
Linux distribution packages (8)
rubygem-activesupport-5_1 SUSE:Linux Enterprise High Availability Extension 15 | All versions | 5.1.4-3.3.1 |
rubygem-activesupport-5_1 SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 5.1.4-3.3.1 |
rubygem-activesupport-5_1 SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 5.1.4-3.3.1 |
rubygem-activesupport-4_2 SUSE:OpenStack Cloud 7 | All versions | 4.2.9-7.9.1 |
rubygem-activesupport-4_2 SUSE:OpenStack Cloud Crowbar 8 | All versions | 4.2.9-7.9.1 |
rubygem-activesupport-4_2 SUSE:OpenStack Cloud Crowbar 9 | All versions | 4.2.9-7.9.1 |
rubygem-activesupport-5_1 openSUSE:Leap 15.1 | All versions | 5.1.4-lp151.3.3.1 |
rubygem-activesupport-5_1 openSUSE:Leap 15.2 | All versions | 5.1.4-lp152.4.3.1 |
Products include Debian Debian Linux, Opensuse Leap, Rubyonrails Rails.
How do I fix CVE-2020-8165?
Upgrade activesupport to a fixed version for your release line: 5.2.4.3 or 6.0.3.1.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2020-8165 being exploited?
There is no known exploitation of CVE-2020-8165 in the wild and no public exploit code.
Public exploit code: 7 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2020-8165, GHSA-2p68-f74v-9wc6, SUSE-SU-2020:2899-1, SUSE-SU-2020:2929-1, UBUNTU-CVE-2020-8165, openSUSE-SU-2020:1677-1 and 1 more.