# CVE-2020-8166: Ability to forge per-form CSRF tokens in Rails

> Attackers can forge per-form CSRF tokens using a global token, bypassing CSRF protections in Ruby on Rails applications.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Jul 2020
- **Updated:** 28 Apr 2026
- **Also known as:** DEBIAN-CVE-2020-8166, GHSA-jp5v-5gx4-jmj9, SUSE-SU-2024:0103-1, UBUNTU-CVE-2020-8166

## What is CVE-2020-8166?

CVE-2020-8166 is a medium-severity vulnerability in Debian Debian Linux, published on 2 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A CSRF forgery vulnerability exists in rails < 5.2.5, rails < 6.0.4 that makes it possible for an attacker to, given a global CSRF token such as the one present in the authenticity_token meta tag, forge a per-form CSRF token.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2020-8166?

4 open source packages ship an affected version, including actionpack. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionpack` | RubyGems | From 5.0.0 | 5.2.4.3 |
| `actionpack` | RubyGems | From 5.0.0 | 5.2.4.3 |
| `actionpack` | RubyGems | From 6.0.0 | 6.0.3.1 |
| `actionpack` | RubyGems | From 6.0.0 | 6.0.3.1 |
| `rubygem-actionpack-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP1 | All versions | 5.1.4-150000.3.29.1 |
| `rubygem-actionpack-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP2 | All versions | 5.1.4-150000.3.29.1 |
| `rubygem-actionpack-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP3 | All versions | 5.1.4-150000.3.29.1 |
| `rubygem-actionpack-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP4 | All versions | 5.1.4-150000.3.29.1 |
| `rubygem-actionpack-5_1` | SUSE:Linux Enterprise High Availability Extension 15 SP5 | All versions | 5.1.4-150000.3.29.1 |
| `rubygem-actionpack-5_1` | openSUSE:Leap 15.4 | All versions | 5.1.4-150000.3.29.1 |
| `rubygem-actionpack-5_1` | openSUSE:Leap 15.5 | All versions | 5.1.4-150000.3.29.1 |

Products: Debian Debian Linux, Rubyonrails Rails.

## How do I fix CVE-2020-8166?

Upgrade actionpack to a fixed version for your release line: 5.2.4.3 or 6.0.3.1.

## Is CVE-2020-8166 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-8166 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8166 and fix it if it is affected.

What it is: CVE-2020-8166 is a medium-severity vulnerability in Debian Debian Linux, published on 2 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-8166 exists.

Affected packages and fixed versions:
- actionpack (RubyGems): affected from 5.0.0; fixed in 5.2.4.3
- actionpack (RubyGems): affected from 5.0.0; fixed in 5.2.4.3
- actionpack (RubyGems): affected from 6.0.0; fixed in 6.0.3.1
- actionpack (RubyGems): affected from 6.0.0; fixed in 6.0.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8166/ (Markdown: https://insights.sbomify.com/CVE-2020-8166/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8166
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8166
- OSV: https://osv.dev/vulnerability/CVE-2020-8166

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8166/
Summaries are generated and may contain mistakes; the official description above is the record.
