CVE-2020-8185 Untrusted users can run pending migrations in production in Rails

Medium 6.5 Published Updated

An untrusted user can trigger pending migrations in production, causing a denial of service in Ruby on Rails applications.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-8185?

CVE-2020-8185 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 2 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A denial of service vulnerability exists in Rails <6.0.3.2 that allowed an untrusted user to run any pending migrations on a Rails app running in production.

Weakness: CWE-400

Which versions are affected by CVE-2020-8185?

2 open source packages ship an affected version, including actionpack. It affects 2 products.

PackageAffectedFixed in
actionpack RubyGemsFrom 6.0.06.0.3.2
actionpack RubyGemsFrom 6.0.06.0.3.2

Products include Fedoraproject Fedora, Rubyonrails Rails.

How do I fix CVE-2020-8185?

Upgrade actionpack to 6.0.3.2 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2020-8185 being exploited?

There is no known exploitation of CVE-2020-8185 in the wild and no public exploit code.

All Fedoraproject Fedora vulnerabilities

Sources

Also known as GHSA-c6qr-h5vq-59jc, UBUNTU-CVE-2020-8185.

Is CVE-2020-8185 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free