# CVE-2020-8186: Injection and Command Injection in devcert

> Attackers can execute arbitrary commands if untrusted input is passed to the certificateFor function in the devcert library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-4228-7qvx-f4rq

## What is CVE-2020-8186?

CVE-2020-8186 is a critical command injection vulnerability in devcert, published on 10 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A command injection vulnerability in the `devcert` module may lead to remote code execution when users of the module pass untrusted input to the `certificateFor` function.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2020-8186?

2 open source packages ship an affected version, including devcert. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `devcert` | npm | All versions | 1.1.2 |
| `devcert` | npm | All versions | 1.1.2 |

Products: Devcert Project Devcert.

## How do I fix CVE-2020-8186?

Upgrade devcert to 1.1.2 or later.

## Is CVE-2020-8186 being exploited?

There is no known exploitation of CVE-2020-8186 in the wild and no public exploit code.

## Other vulnerabilities in devcert

- [CVE-2022-1929](https://insights.sbomify.com/CVE-2022-1929/): Exponential ReDoS in devcert (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8186 and fix it if it is affected.

What it is: CVE-2020-8186 is a critical command injection vulnerability in devcert, published on 10 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-8186 in the wild and no public exploit code.

Affected packages and fixed versions:
- devcert (npm): affected all versions; fixed in 1.1.2
- devcert (npm): affected all versions; fixed in 1.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8186/ (Markdown: https://insights.sbomify.com/CVE-2020-8186/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8186
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8186
- OSV: https://osv.dev/vulnerability/CVE-2020-8186

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8186/
Summaries are generated and may contain mistakes; the official description above is the record.
