# CVE-2020-8205: Server-Side Request Forgery in @uppy/companion

> An attacker can exploit a Server-Side Request Forgery flaw in the Uppy library to scan networks or access internal systems.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-9m4x-8w29-r78g

## What is CVE-2020-8205?

CVE-2020-8205 is a high-severity server-side request forgery vulnerability in uppy, published on 20 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The uppy npm package < 1.13.2 and < 2.0.0-alpha.5 is vulnerable to a Server-Side Request Forgery (SSRF) vulnerability, which allows an attacker to scan local or external networks or otherwise interact with internal systems.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2020-8205?

4 open source packages ship an affected version, including @uppy/companion. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@uppy/companion` | npm | All versions | 1.13.2 |
| `@uppy/companion` | npm | All versions | 1.13.2 |
| `@uppy/companion` | npm | From 2.0.0-alpha.0 | 2.0.0-alpha.5 |
| `@uppy/companion` | npm | From 2.0.0-alpha.0 | 2.0.0-alpha.5 |

Products: Transloadit Uppy.

## How do I fix CVE-2020-8205?

Upgrade @uppy/companion to a fixed version for your release line: 1.13.2 or 2.0.0-alpha.5.

## Is CVE-2020-8205 being exploited?

There is no known exploitation of CVE-2020-8205 in the wild and no public exploit code.

## Other vulnerabilities in uppy

- [CVE-2022-0086](https://insights.sbomify.com/CVE-2022-0086/): Server-Side Request Forgery (SSRF) in transloadit/uppy (high 8.2)
- [CVE-2022-0528](https://insights.sbomify.com/CVE-2022-0528/): Server-Side Request Forgery (SSRF) in transloadit/uppy (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8205 and fix it if it is affected.

What it is: CVE-2020-8205 is a high-severity server-side request forgery vulnerability in uppy, published on 20 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-8205 in the wild and no public exploit code.

Affected packages and fixed versions:
- @uppy/companion (npm): affected all versions; fixed in 1.13.2
- @uppy/companion (npm): affected all versions; fixed in 1.13.2
- @uppy/companion (npm): affected from 2.0.0-alpha.0; fixed in 2.0.0-alpha.5
- @uppy/companion (npm): affected from 2.0.0-alpha.0; fixed in 2.0.0-alpha.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8205/ (Markdown: https://insights.sbomify.com/CVE-2020-8205/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8205
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8205
- OSV: https://osv.dev/vulnerability/CVE-2020-8205

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8205/
Summaries are generated and may contain mistakes; the official description above is the record.
