# CVE-2020-8214: Path traversal in servey

> An attacker can read arbitrary files on the server due to a path traversal vulnerability in the servey library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-v3px-6cc8-f8j3

## What is CVE-2020-8214?

CVE-2020-8214 is a high-severity path traversal vulnerability in servey, published on 20 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A path traversal vulnerability in servey version < 3 allows an attacker to read content of any arbitrary file.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2020-8214?

2 open source packages ship an affected version, including servey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `servey` | npm | All versions | 3.3.2 |
| `servey` | npm | All versions | 3.3.2 |

Products: Servey Project Servey.

## How do I fix CVE-2020-8214?

Upgrade servey to 3.3.2 or later.

## Is CVE-2020-8214 being exploited?

There is no known exploitation of CVE-2020-8214 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8214 and fix it if it is affected.

What it is: CVE-2020-8214 is a high-severity path traversal vulnerability in servey, published on 20 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-8214 in the wild and no public exploit code.

Affected packages and fixed versions:
- servey (npm): affected all versions; fixed in 3.3.2
- servey (npm): affected all versions; fixed in 3.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8214/ (Markdown: https://insights.sbomify.com/CVE-2020-8214/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8214
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8214
- OSV: https://osv.dev/vulnerability/CVE-2020-8214

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8214/
Summaries are generated and may contain mistakes; the official description above is the record.
