CVE-2020-8215 Buffer overflow in canvas

High 8.8 Published Updated

A buffer overflow in the node-canvas library allows attackers to execute arbitrary code or cause denial of service via malicious images.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-8215?

CVE-2020-8215 is a high-severity memory corruption vulnerability in node-canvas, published on 20 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A buffer overflow is present in canvas version <= 1.6.9, which could lead to a Denial of Service or execution of arbitrary code when it processes a user-provided image.

Weakness: CWE-120

Which versions are affected by CVE-2020-8215?

2 open source packages ship an affected version, including canvas. It affects 1 product.

PackageAffectedFixed in
canvas npmAll versions1.6.11
canvas npmAll versions1.6.11

Products include Automattic Canvas.

How do I fix CVE-2020-8215?

Upgrade canvas to 1.6.11 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2020-8215 being exploited?

There is no known exploitation of CVE-2020-8215 in the wild and no public exploit code.

Sources

Also known as GHSA-73rg-x683-m3qw.

Is CVE-2020-8215 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free