# CVE-2020-8215: Buffer overflow in canvas

> A buffer overflow in the node-canvas library allows attackers to execute arbitrary code or cause denial of service via malicious images.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-73rg-x683-m3qw

## What is CVE-2020-8215?

CVE-2020-8215 is a high-severity memory corruption vulnerability in node-canvas, published on 20 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A buffer overflow is present in canvas version <= 1.6.9, which could lead to a Denial of Service or execution of arbitrary code when it processes a user-provided image.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2020-8215?

2 open source packages ship an affected version, including canvas. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `canvas` | npm | All versions | 1.6.11 |
| `canvas` | npm | All versions | 1.6.11 |

Products: Automattic Canvas.

## How do I fix CVE-2020-8215?

Upgrade canvas to 1.6.11 or later.

## Is CVE-2020-8215 being exploited?

There is no known exploitation of CVE-2020-8215 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8215 and fix it if it is affected.

What it is: CVE-2020-8215 is a high-severity memory corruption vulnerability in node-canvas, published on 20 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-8215 in the wild and no public exploit code.

Affected packages and fixed versions:
- canvas (npm): affected all versions; fixed in 1.6.11
- canvas (npm): affected all versions; fixed in 1.6.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8215/ (Markdown: https://insights.sbomify.com/CVE-2020-8215/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8215
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8215
- OSV: https://osv.dev/vulnerability/CVE-2020-8215

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8215/
Summaries are generated and may contain mistakes; the official description above is the record.
