CVE-2020-8226 phpBB Server-Side Request Forgery Vulnerability

Medium 5.8 Published Updated

Remote attackers can exploit a flaw in phpBB's image dimension checking to perform Server-Side Request Forgery, potentially accessing internal resources.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2020-8226?

CVE-2020-8226 is a medium-severity server-side request forgery vulnerability in https://github.com/phpbb/phpbb, published on 17 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability exists in phpBB <v3.2.10 and <v3.3.1 which allowed remote image dimensions check to be used to SSRF.

Weakness: CWE-918, CWE-610

Which versions are affected by CVE-2020-8226?

5 open source packages ship an affected version, including phpbb/phpbb and phpbb. It affects 1 product.

PackageAffectedFixed in
phpbb/phpbb PackagistFrom 3.2.03.2.10
phpbb/phpbb PackagistFrom 3.2.03.2.10
phpbb/phpbb PackagistFrom 3.3.03.3.1
phpbb/phpbb PackagistFrom 3.3.03.3.1
phpbb BitnamiAll versions3.2.10, 3.3.1

Products include Phpbb Phpbb.

How do I fix CVE-2020-8226?

Upgrade phpbb/phpbb to a fixed version for your release line: 3.2.10 or 3.3.1.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2020-8226 being exploited?

There is no known exploitation of CVE-2020-8226 in the wild and no public exploit code.

Sources

Also known as BIT-phpbb-2020-8226, GHSA-jhm9-h84h-rw83, UBUNTU-CVE-2020-8226.

Is CVE-2020-8226 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free