# CVE-2020-8265: Use after free in Node

> A use-after-free bug in Node.js TLS implementation allows attackers to corrupt memory, causing denial of service or potential code execution.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jan 2021
- **Updated:** 30 Apr 2025
- **Also known as:** ALPINE-CVE-2020-8265, BIT-node-2020-8265, BIT-node-min-2020-8265, CLEANSTART-2026-ES54062, CLEANSTART-2026-KN57081, DEBIAN-CVE-2020-8265, GHSA-879w-9vpf-9pw9, UBUNTU-CVE-2020-8265

## What is CVE-2020-8265?

CVE-2020-8265 is a high-severity use after free vulnerability in Debian Debian Linux, published on 6 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Node.js versions before 10.23.1, 12.20.1, 14.15.4, 15.5.1 are vulnerable to a use-after-free bug in its TLS implementation. When writing to a TLS enabled socket, node::StreamBase::Write calls node::TLSWrap::DoWrite with a freshly allocated WriteWrap object as first argument. If the DoWrite method does not return an error, this object is passed back to the caller as part of a StreamWriteResult structure. This may be exploited to corrupt memory leading to a Denial of Service or potentially other exploits.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2020-8265?

2 open source packages ship an affected version, including node and node-min. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 10.0.0 | 10.23.1, 12.20.1, 14.15.4, 15.5.1 |
| `node-min` | Bitnami | From 10.0.0 | 10.23.1, 12.20.1, 14.15.4, 15.5.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Nodejs Node.js, Oracle Graalvm, Siemens Sinec Infrastructure Network Services.

## How do I fix CVE-2020-8265?

Upgrade node to a fixed version for your release line: 10.23.1, 12.20.1, 14.15.4 or 15.5.1.

## Is CVE-2020-8265 being exploited?

There is no known exploitation of CVE-2020-8265 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8265 and fix it if it is affected.

What it is: CVE-2020-8265 is a high-severity use after free vulnerability in Debian Debian Linux, published on 6 Jan 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-8265 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 10.0.0; fixed in 10.23.1, 12.20.1, 14.15.4, 15.5.1
- node-min (Bitnami): affected from 10.0.0; fixed in 10.23.1, 12.20.1, 14.15.4, 15.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8265/ (Markdown: https://insights.sbomify.com/CVE-2020-8265/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8265
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8265
- OSV: https://osv.dev/vulnerability/CVE-2020-8265

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8265/
Summaries are generated and may contain mistakes; the official description above is the record.
