# CVE-2020-8268: Prototype pollution in json8-merge-patch

> Attackers can inject or modify global object properties via prototype pollution in the json8-merge-patch library, potentially leading to code execution.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Nov 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-8v9x-9xqg-r8mr

## What is CVE-2020-8268?

CVE-2020-8268 is a high-severity code injection vulnerability in json8-merge-patch, published on 9 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Prototype pollution vulnerability in json8-merge-patch npm package < 1.0.3 may allow attackers to inject or modify methods and properties of the global object constructor.

Weakness: CWE-20 (Improper Input Validation), CWE-471 (Modification of Assumed-Immutable Data (MAID))

## Which versions are affected by CVE-2020-8268?

2 open source packages ship an affected version, including json8-merge-patch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `json8-merge-patch` | npm | All versions | 1.0.3 |
| `json8-merge-patch` | npm | All versions | 1.0.3 |

Products: Json8-Merge-Patch Project Json8-Merge-Patch.

## How do I fix CVE-2020-8268?

Upgrade json8-merge-patch to 1.0.3 or later.

## Is CVE-2020-8268 being exploited?

There is no known exploitation of CVE-2020-8268 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8268 and fix it if it is affected.

What it is: CVE-2020-8268 is a high-severity code injection vulnerability in json8-merge-patch, published on 9 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-8268 in the wild and no public exploit code.

Affected packages and fixed versions:
- json8-merge-patch (npm): affected all versions; fixed in 1.0.3
- json8-merge-patch (npm): affected all versions; fixed in 1.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8268/ (Markdown: https://insights.sbomify.com/CVE-2020-8268/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8268
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8268
- OSV: https://osv.dev/vulnerability/CVE-2020-8268

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8268/
Summaries are generated and may contain mistakes; the official description above is the record.
