CVE-2020-8277 Uncontrolled Resource Consumption in node
An attacker can cause a Denial of Service in Node.js applications by triggering excessive DNS responses, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-8277?
CVE-2020-8277 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 19 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A Node.js application that allows an attacker to trigger a DNS request for a host of their choice could trigger a Denial of Service in versions < 15.2.1, < 14.15.1, and < 12.19.1 by getting the application to resolve a DNS record with a larger number of responses. This is fixed in 15.2.1, 14.15.1, and 12.19.1.
Weakness: CWE-400
Which versions are affected by CVE-2020-8277?
2 open source packages ship an affected version, including node and node-min. It affects 8 products.
| Package | Affected | Fixed in |
|---|---|---|
node Bitnami | From 12.16.3 | 12.19.1, 14.15.1, 15.2.1 |
node-min Bitnami | From 12.16.3 | 12.19.1, 14.15.1, 15.2.1 |
Linux distribution packages (11)
c-ares SUSE:Linux Enterprise High Performance Computing 15-ESPOS | All versions | 1.17.0-3.8.1 |
c-ares SUSE:Linux Enterprise High Performance Computing 15-LTSS | All versions | 1.17.0-3.8.1 |
c-ares SUSE:Linux Enterprise Module for Basesystem 15 SP1 | All versions | 1.17.0-3.8.1 |
c-ares SUSE:Linux Enterprise Module for Basesystem 15 SP2 | All versions | 1.17.0-3.8.1 |
nodejs12 SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 12.19.1-1.23.1 |
c-ares SUSE:Linux Enterprise Server 15-LTSS | All versions | 1.17.0-3.8.1 |
c-ares SUSE:Linux Enterprise Server for SAP Applications 15 | All versions | 1.17.0-3.8.1 |
c-ares openSUSE:Leap 15.1 | All versions | 1.17.0-lp151.3.6.1 |
c-ares-tests openSUSE:Leap 15.1 | All versions | 1.17.0-lp151.3.6.1 |
c-ares openSUSE:Leap 15.2 | All versions | 1.17.0-lp152.2.3.1 |
c-ares-tests openSUSE:Leap 15.2 | All versions | 1.17.0-lp152.2.3.1 |
Products include C-Ares Project C-Ares, Fedoraproject Fedora, Nodejs Node.js, Oracle Blockchain Platform, Oracle Graalvm, Oracle Jd Edwards Enterpriseone Tools and 2 more.
How do I fix CVE-2020-8277?
Upgrade node to a fixed version for your release line: 12.19.1, 14.15.1 or 15.2.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-8277 being exploited?
There is no known exploitation of CVE-2020-8277 in the wild and no public exploit code.
Public exploit code: 2 proofs of concept on GitHub.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as ALPINE-CVE-2020-8277, AZL-32281, BIT-node-2020-8277, BIT-node-min-2020-8277, CLEANSTART-2026-KV06293, CLEANSTART-2026-LV83462 and 8 more.