# CVE-2020-8277: Uncontrolled Resource Consumption in node

> An attacker can cause a Denial of Service in Node.js applications by triggering excessive DNS responses, requiring an upgrade to patched versions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Nov 2020
- **Updated:** 30 Apr 2025
- **Also known as:** ALPINE-CVE-2020-8277, AZL-32281, BIT-node-2020-8277, BIT-node-min-2020-8277, CLEANSTART-2026-KV06293, CLEANSTART-2026-LV83462, DEBIAN-CVE-2020-8277, ECHO-f2bd-57d2-fe00, GHSA-m5pg-8h68-j225, OESA-2021-1099, SUSE-SU-2020:3478-1, SUSE-SU-2020:3549-1, openSUSE-SU-2020:2045-1, openSUSE-SU-2020:2092-1

## What is CVE-2020-8277?

CVE-2020-8277 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 19 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Node.js application that allows an attacker to trigger a DNS request for a host of their choice could trigger a Denial of Service in versions < 15.2.1, < 14.15.1, and < 12.19.1 by getting the application to resolve a DNS record with a larger number of responses. This is fixed in 15.2.1, 14.15.1, and 12.19.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2020-8277?

2 open source packages ship an affected version, including node and node-min. It affects 8 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node` | Bitnami | From 12.16.3 | 12.19.1, 14.15.1, 15.2.1 |
| `node-min` | Bitnami | From 12.16.3 | 12.19.1, 14.15.1, 15.2.1 |
| `c-ares` | SUSE:Linux Enterprise High Performance Computing 15-ESPOS | All versions | 1.17.0-3.8.1 |
| `c-ares` | SUSE:Linux Enterprise High Performance Computing 15-LTSS | All versions | 1.17.0-3.8.1 |
| `c-ares` | SUSE:Linux Enterprise Module for Basesystem 15 SP1 | All versions | 1.17.0-3.8.1 |
| `c-ares` | SUSE:Linux Enterprise Module for Basesystem 15 SP2 | All versions | 1.17.0-3.8.1 |
| `nodejs12` | SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 12.19.1-1.23.1 |
| `c-ares` | SUSE:Linux Enterprise Server 15-LTSS | All versions | 1.17.0-3.8.1 |
| `c-ares` | SUSE:Linux Enterprise Server for SAP Applications 15 | All versions | 1.17.0-3.8.1 |
| `c-ares` | openSUSE:Leap 15.1 | All versions | 1.17.0-lp151.3.6.1 |
| `c-ares-tests` | openSUSE:Leap 15.1 | All versions | 1.17.0-lp151.3.6.1 |
| `c-ares` | openSUSE:Leap 15.2 | All versions | 1.17.0-lp152.2.3.1 |
| `c-ares-tests` | openSUSE:Leap 15.2 | All versions | 1.17.0-lp152.2.3.1 |

Products: C-Ares Project C-Ares, Fedoraproject Fedora, Nodejs Node.js, Oracle Blockchain Platform, Oracle Graalvm, Oracle Jd Edwards Enterpriseone Tools, Oracle Mysql Cluster, Oracle Retail Xstore Point of Service.

## How do I fix CVE-2020-8277?

Upgrade node to a fixed version for your release line: 12.19.1, 14.15.1 or 15.2.1.

## Is CVE-2020-8277 being exploited?

There is no known exploitation of CVE-2020-8277 in the wild and no public exploit code.

Public exploit code:

- https://github.com/masahiro331/CVE-2020-8277 (github_poc): https://github.com/masahiro331/CVE-2020-8277
- https://github.com/AndrewIjano/CVE-2020-8277 (github_poc): https://github.com/AndrewIjano/CVE-2020-8277

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2022-4904](https://insights.sbomify.com/CVE-2022-4904/): Memory corruption in c-ares (high 8.6)
- [CVE-2023-32067](https://insights.sbomify.com/CVE-2023-32067/): 0-byte UDP payload DoS in c-ares (high 7.5)
- [CVE-2023-31147](https://insights.sbomify.com/CVE-2023-31147/): Insufficient randomness in generation of DNS query IDs in c-ares (medium 5.9)
- [CVE-2021-3672](https://insights.sbomify.com/CVE-2021-3672/): Other in c-ares (medium 5.6)
- [CVE-2023-31130](https://insights.sbomify.com/CVE-2023-31130/): Buffer Underwrite in ares_inet_net_pton() (medium 4.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8277 and fix it if it is affected.

What it is: CVE-2020-8277 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 19 Nov 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-8277 in the wild and no public exploit code.

Affected packages and fixed versions:
- node (Bitnami): affected from 12.16.3; fixed in 12.19.1, 14.15.1, 15.2.1
- node-min (Bitnami): affected from 12.16.3; fixed in 12.19.1, 14.15.1, 15.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8277/ (Markdown: https://insights.sbomify.com/CVE-2020-8277/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8277
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8277
- OSV: https://osv.dev/vulnerability/CVE-2020-8277

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8277/
Summaries are generated and may contain mistakes; the official description above is the record.
