CVE-2020-8287 Node.js versions before 10.23.1, 12.20.1, 14.15.4, 15.5.1 allow two copies of a header field in an HTTP request (for example, two Transfer-E
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2020-8287?
CVE-2020-8287 is a medium-severity vulnerability in Debian Debian Linux, published on 6 Jan 2021.
Official description
Node.js versions before 10.23.1, 12.20.1, 14.15.4, 15.5.1 allow two copies of a header field in an HTTP request (for example, two Transfer-Encoding header fields). In this case, Node.js identifies the first header field and ignores the second. This can lead to HTTP Request Smuggling.
Weakness: CWE-444
Which versions are affected by CVE-2020-8287?
2 open source packages ship an affected version, including node and node-min. It affects 5 products.
| Package | Affected | Fixed in |
|---|---|---|
node Bitnami | From 10.0.0 | 10.23.1, 12.20.1, 14.15.4, 15.5.1 |
node-min Bitnami | From 10.0.0 | 10.23.1, 12.20.1, 14.15.4, 15.5.1 |
Linux distribution packages (15)
nodejs8 SUSE:Enterprise Storage 6 | All versions | 8.17.0-3.42.2 |
nodejs8 SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS | All versions | 8.17.0-3.42.2 |
nodejs8 SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 8.17.0-3.42.2 |
nodejs8 SUSE:Linux Enterprise High Performance Computing 15-ESPOS | All versions | 8.17.0-3.42.2 |
nodejs8 SUSE:Linux Enterprise High Performance Computing 15-LTSS | All versions | 8.17.0-3.42.2 |
nodejs8 SUSE:Linux Enterprise Module for Web and Scripting 15 SP2 | All versions | 8.17.0-10.6.1 |
nodejs8 SUSE:Linux Enterprise Server 15 SP1-BCL | All versions | 8.17.0-3.42.2 |
nodejs8 SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 8.17.0-3.42.2 |
nodejs8 SUSE:Linux Enterprise Server 15-LTSS | All versions | 8.17.0-3.42.2 |
nodejs8 SUSE:Linux Enterprise Server for SAP Applications 15 | All versions | 8.17.0-3.42.2 |
nodejs8 SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 8.17.0-3.42.2 |
nodejs8 SUSE:Manager Proxy 4.0 | All versions | 8.17.0-3.42.2 |
nodejs8 SUSE:Manager Retail Branch Server 4.0 | All versions | 8.17.0-3.42.2 |
nodejs8 SUSE:Manager Server 4.0 | All versions | 8.17.0-3.42.2 |
nodejs8 openSUSE:Leap 15.2 | All versions | 8.17.0-lp152.3.8.1 |
Products include Debian Debian Linux, Fedoraproject Fedora, Nodejs Node.js, Oracle Graalvm, Siemens Sinec Infrastructure Network Services.
How do I fix CVE-2020-8287?
Upgrade node to a fixed version for your release line: 10.23.1, 12.20.1, 14.15.4 or 15.5.1.
Is CVE-2020-8287 being exploited?
There is no known exploitation of CVE-2020-8287 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2020-8287, BIT-node-2020-8287, BIT-node-min-2020-8287, CLEANSTART-2026-LT93130, CLEANSTART-2026-TY43292, DEBIAN-CVE-2020-8287 and 8 more.