# CVE-2020-8315: Other in n/a

> An attacker can execute arbitrary code by placing a malicious DLL in the application directory on Windows 7 systems running Python.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Jan 2020
- **Updated:** 14 Oct 2026
- **Also known as:** ALPINE-CVE-2020-8315, BIT-libpython-2020-8315, BIT-python-2020-8315, BIT-python-min-2020-8315, CLEANSTART-2026-LG19645, GHSA-646c-5wg7-pw2g, PSF-2020-7

## What is CVE-2020-8315?

CVE-2020-8315 is a medium-severity vulnerability in Python Python, published on 28 Jan 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In Python (CPython) 3.6 through 3.6.10, 3.7 through 3.7.6, and 3.8 through 3.8.1, an insecure dependency load upon launch on Windows 7 may result in an attacker's copy of api-ms-win-core-path-l1-1-0.dll being loaded and used instead of the system's copy. Windows 8 and later are unaffected.

Weakness: CWE-427 (Uncontrolled Search Path Element)

## Which versions are affected by CVE-2020-8315?

3 open source packages ship an affected version, including libpython, python and python-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libpython` | Bitnami | From 3.6.0 | 3.6.11, 3.7.7, 3.8.2 |
| `python` | Bitnami | From 3.6.0 | 3.6.11, 3.7.7, 3.8.2 |
| `python-min` | Bitnami | From 3.6.0 | 3.6.11, 3.7.7, 3.8.2 |

Products: Python Python.

## How do I fix CVE-2020-8315?

Upgrade libpython to a fixed version for your release line: 3.6.11, 3.7.7 or 3.8.2.

## Is CVE-2020-8315 being exploited?

There is no known exploitation of CVE-2020-8315 in the wild and no public exploit code.

## Other vulnerabilities in Python Python

- [CVE-2008-5031](https://insights.sbomify.com/CVE-2008-5031/): Integer overflow in n/a (critical 10.0)
- [CVE-2014-4650](https://insights.sbomify.com/CVE-2014-4650/): Path traversal in n/a (critical 9.8)
- [CVE-2016-5636](https://insights.sbomify.com/CVE-2016-5636/): Integer overflow in n/a (critical 9.8)
- [CVE-2007-4559](https://insights.sbomify.com/CVE-2007-4559/): Path traversal in n/a (critical 9.8)
- [CVE-2017-17522](https://insights.sbomify.com/CVE-2017-17522/): Command injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8315 and fix it if it is affected.

What it is: CVE-2020-8315 is a medium-severity vulnerability in Python Python, published on 28 Jan 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-8315 in the wild and no public exploit code.

Affected packages and fixed versions:
- libpython (Bitnami): affected from 3.6.0; fixed in 3.6.11, 3.7.7, 3.8.2
- python (Bitnami): affected from 3.6.0; fixed in 3.6.11, 3.7.7, 3.8.2
- python-min (Bitnami): affected from 3.6.0; fixed in 3.6.11, 3.7.7, 3.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8315/ (Markdown: https://insights.sbomify.com/CVE-2020-8315/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8315
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8315
- OSV: https://osv.dev/vulnerability/CVE-2020-8315

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8315/
Summaries are generated and may contain mistakes; the official description above is the record.
