CVE-2020-8559 Privilege escalation from compromised node to cluster
An attacker with node access can exploit an unvalidated redirect in proxied upgrade requests to escalate privileges to full cluster control.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-8559?
CVE-2020-8559 is a medium-severity vulnerability in Kubernetes Kubernetes, published on 22 Jul 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
The Kubernetes kube-apiserver in versions v1.6-v1.15, and versions prior to v1.16.13, v1.17.9 and v1.18.6 are vulnerable to an unvalidated redirect on proxied upgrade requests that could allow an attacker to escalate privileges from a node compromise to a full cluster compromise.
Weakness: CWE-601
Which versions are affected by CVE-2020-8559?
14 open source packages ship an affected version, including k8s.io/kubernetes and k8s.io/apimachinery. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
k8s.io/kubernetes Go | All versions | 1.16.13, 1.17.9, 1.18.7 |
k8s.io/kubernetes Go | All versions | 1.16.13 |
k8s.io/kubernetes Go | All versions | 1.16.13 |
k8s.io/kubernetes Go | From 1.17.0 | 1.17.9 |
k8s.io/kubernetes Go | From 1.17.0 | 1.17.9 |
k8s.io/kubernetes Go | From 1.18.0 | 1.18.7 |
8 more packages
k8s.io/kubernetes Go | From 1.18.0 | 1.18.7 |
k8s.io/apimachinery Go | All versions | 0.16.13, 0.17.9, 0.18.7-rc.0 |
k8s.io/apimachinery Go | All versions | 0.16.13 |
k8s.io/apimachinery Go | All versions | 0.16.13 |
k8s.io/apimachinery Go | From 0.17.0 | 0.17.9 |
k8s.io/apimachinery Go | From 0.17.0 | 0.17.9 |
k8s.io/apimachinery Go | From 0.18.0 | 0.18.7 |
k8s.io/apimachinery Go | From 0.18.0 | 0.18.7 |
Linux distribution packages (4)
openshift Red Hat:openshift:4.4::el7 | All versions | 0:4.4.0-202012052258.p0.git.0.0fd57a4.el7 |
openshift-hyperkube Red Hat:openshift:4.4::el7 | All versions | 0:4.4.0-202012052258.p0.git.0.0fd57a4.el7 |
openshift Red Hat:openshift:4.4::el8 | All versions | 0:4.4.0-202012052258.p0.git.0.0fd57a4.el8 |
openshift-hyperkube Red Hat:openshift:4.4::el8 | All versions | 0:4.4.0-202012052258.p0.git.0.0fd57a4.el8 |
Products include Kubernetes Kubernetes.
How do I fix CVE-2020-8559?
Upgrade k8s.io/kubernetes to a fixed version for your release line: 1.16.13, 1.17.9 or 1.18.7.
Is CVE-2020-8559 being exploited?
There is no known exploitation of CVE-2020-8559 in the wild and no public exploit code.
Public exploit code: 2 proofs of concept on GitHub.
Other vulnerabilities in Kubernetes Kubernetes
- CVE-2018-1002105 Privilege Escalation in Kubernetes
- CVE-2017-1000056 Kubernetes Privilege Escalation
- CVE-2016-1906 Authorization bypass in Openshift
- CVE-2023-3676 Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation
- CVE-2023-3955 Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation
Sources
Also known as CLEANSTART-2025-JT47341, CLEANSTART-2026-JX77218, CLEANSTART-2026-RN37949, DEBIAN-CVE-2020-8559, GHSA-33c5-9fx5-fvjm, GO-2024-2748 and 1 more.