CVE-2020-8663 Denial of service in n/a
Attackers can exhaust file descriptors or memory by opening excessive connections, causing a denial of service in Envoy proxy deployments.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-8663?
CVE-2020-8663 is a high-severity denial of service vulnerability in Envoyproxy Envoy, published on 1 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Envoy version 1.14.2, 1.13.2, 1.12.4 or earlier may exhaust file descriptors and/or memory when accepting too many connections.
Weakness: CWE-400
Which versions are affected by CVE-2020-8663?
1 open source package ship an affected version, including envoy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
envoy Bitnami | All versions | 1.12.5, 1.13.3, 1.14.3 |
Products include Envoyproxy Envoy.
How do I fix CVE-2020-8663?
Upgrade envoy to a fixed version for your release line: 1.12.5, 1.13.3 or 1.14.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-8663 being exploited?
There is no known exploitation of CVE-2020-8663 in the wild and no public exploit code.
Other vulnerabilities in Envoyproxy Envoy
Sources
Also known as BIT-envoy-2020-8663, GHSA-v8q7-fq78-4997.