# CVE-2020-8663: Denial of service in n/a

> Attackers can exhaust file descriptors or memory by opening excessive connections, causing a denial of service in Envoy proxy deployments.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-envoy-2020-8663, GHSA-v8q7-fq78-4997

## What is CVE-2020-8663?

CVE-2020-8663 is a high-severity denial of service vulnerability in Envoyproxy Envoy, published on 1 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Envoy version 1.14.2, 1.13.2, 1.12.4 or earlier may exhaust file descriptors and/or memory when accepting too many connections.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2020-8663?

1 open source package ship an affected version, including envoy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `envoy` | Bitnami | All versions | 1.12.5, 1.13.3, 1.14.3 |

Products: Envoyproxy Envoy.

## How do I fix CVE-2020-8663?

Upgrade envoy to a fixed version for your release line: 1.12.5, 1.13.3 or 1.14.3.

## Is CVE-2020-8663 being exploited?

There is no known exploitation of CVE-2020-8663 in the wild and no public exploit code.

## Other vulnerabilities in Envoyproxy Envoy

- [CVE-2022-29226](https://insights.sbomify.com/CVE-2022-29226/): Trivial authentication bypass in Envoy (critical 10.0)
- [CVE-2019-18801](https://insights.sbomify.com/CVE-2019-18801/): Memory corruption in n/a (critical 9.8)
- [CVE-2019-18802](https://insights.sbomify.com/CVE-2019-18802/): Security feature bypass in n/a (critical 9.8)
- [CVE-2020-35470](https://insights.sbomify.com/CVE-2020-35470/): Information disclosure in n/a (high 8.8)
- [CVE-2024-23324](https://insights.sbomify.com/CVE-2024-23324/): Envoy ext auth can be bypassed when Proxy protocol filter sets invalid UTF-8 metadata (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8663 and fix it if it is affected.

What it is: CVE-2020-8663 is a high-severity denial of service vulnerability in Envoyproxy Envoy, published on 1 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-8663 in the wild and no public exploit code.

Affected packages and fixed versions:
- envoy (Bitnami): affected all versions; fixed in 1.12.5, 1.13.3, 1.14.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8663/ (Markdown: https://insights.sbomify.com/CVE-2020-8663/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8663
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8663
- OSV: https://osv.dev/vulnerability/CVE-2020-8663

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8663/
Summaries are generated and may contain mistakes; the official description above is the record.
