CVE-2020-8776 Cross-site scripting in n/a

Medium 5.4 Published Updated

Attackers can execute arbitrary scripts in victim browsers via a malicious file URL property in Alfresco, potentially leading to session hijacking.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-8776?

CVE-2020-8776 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Alfresco Enterprise before 5.2.7 and Alfresco Community before 6.2.0 (rb65251d6-b368) has XSS via the URL property of a file.

Weakness: CWE-79

Which versions are affected by CVE-2020-8776?

1 open source package ship an affected version, including alfresco. It affects 1 product.

PackageAffectedFixed in
alfresco BitnamiAll versions5.2.7, 6.2.0

Products include Alfresco Alfresco.

How do I fix CVE-2020-8776?

Upgrade alfresco to a fixed version for your release line: 5.2.7 or 6.2.0.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-8776 being exploited?

There is no known exploitation of CVE-2020-8776 in the wild and no public exploit code.

Public exploit code: 1 Exploit-DB entry.

Sources

Also known as BIT-alfresco-2020-8776, GHSA-3pw8-m4pc-4r7g.

Is CVE-2020-8776 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free