CVE-2020-8777 Cross-site scripting in n/a

Medium 5.4 Published Updated

Attackers can execute arbitrary scripts via malicious SVG profile photos, potentially compromising user accounts in Alfresco.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-8777?

CVE-2020-8777 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Alfresco Enterprise before 5.2.7 and Alfresco Community before 6.2.0 (rb65251d6-b368) has XSS via a user profile photo, as demonstrated by a SCRIPT element in an SVG document.

Weakness: CWE-79

Which versions are affected by CVE-2020-8777?

1 open source package ship an affected version, including alfresco. It affects 1 product.

PackageAffectedFixed in
alfresco BitnamiAll versions5.2.7, 6.2.0

Products include Alfresco Alfresco.

How do I fix CVE-2020-8777?

Upgrade alfresco to a fixed version for your release line: 5.2.7 or 6.2.0.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-8777 being exploited?

There is no known exploitation of CVE-2020-8777 in the wild and no public exploit code.

Public exploit code: 1 Exploit-DB entry.

Sources

Also known as BIT-alfresco-2020-8777, GHSA-p3vq-v25w-6m97.

Is CVE-2020-8777 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free