# CVE-2020-8778: Cross-site scripting in n/a

> An attacker with write access can inject malicious scripts via uploaded documents, potentially leading to code execution or account takeover in Alfresco.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-alfresco-2020-8778, GHSA-3wq2-f93g-wx78

## What is CVE-2020-8778?

CVE-2020-8778 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Alfresco Enterprise before 5.2.7 and Alfresco Community before 6.2.0 (rb65251d6-b368) has XSS via an uploaded document, when the attacker has write access to a project.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-8778?

1 open source package ship an affected version, including alfresco. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `alfresco` | Bitnami | All versions | 5.2.7, 6.2.0 |

Products: Alfresco Alfresco.

## How do I fix CVE-2020-8778?

Upgrade alfresco to a fixed version for your release line: 5.2.7 or 6.2.0.

## Is CVE-2020-8778 being exploited?

There is no known exploitation of CVE-2020-8778 in the wild and no public exploit code.

Public exploit code:

- Alfresco 5.2.4 - Persistent Cross-Site Scripting (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2019-14222](https://insights.sbomify.com/CVE-2019-14222/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2019-15566](https://insights.sbomify.com/CVE-2019-15566/): SQL injection in n/a (critical 9.8)
- [CVE-2019-14224](https://insights.sbomify.com/CVE-2019-14224/): Deserialization in n/a (high 7.2)
- [CVE-2014-9300](https://insights.sbomify.com/CVE-2014-9300/): Cross-site request forgery in n/a (medium 6.8)
- [CVE-2014-9301](https://insights.sbomify.com/CVE-2014-9301/): Server-side request forgery in n/a (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8778 and fix it if it is affected.

What it is: CVE-2020-8778 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Mar 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-8778 in the wild and no public exploit code.

Affected packages and fixed versions:
- alfresco (Bitnami): affected all versions; fixed in 5.2.7, 6.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8778/ (Markdown: https://insights.sbomify.com/CVE-2020-8778/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8778
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8778
- OSV: https://osv.dev/vulnerability/CVE-2020-8778

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8778/
Summaries are generated and may contain mistakes; the official description above is the record.
