# CVE-2020-8823: Cross-site scripting in SocksJS-node

> Reflected XSS in SockJS allows attackers to execute arbitrary scripts in victim browsers via the callback parameter.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-hh8v-jmh3-9437, SNYK-JS-SOCKJS-548397

## What is CVE-2020-8823?

CVE-2020-8823 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

htmlfile in lib/transport/htmlfile.js in SockJS before 0.3.0 is vulnerable to Reflected XSS via the /htmlfile c (aka callback) parameter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-8823?

2 open source packages ship an affected version, including sockjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sockjs` | npm | All versions | 0.3.0 |
| `sockjs` | npm | All versions | 0.3.0 |

Products: Sockjs Project Sockjs.

## How do I fix CVE-2020-8823?

Upgrade sockjs to 0.3.0 or later.

## Is CVE-2020-8823 being exploited?

There is no known exploitation of CVE-2020-8823 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-7693](https://insights.sbomify.com/CVE-2020-7693/): Denial of Service (DoS) (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8823 and fix it if it is affected.

What it is: CVE-2020-8823 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Feb 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-8823 in the wild and no public exploit code.

Affected packages and fixed versions:
- sockjs (npm): affected all versions; fixed in 0.3.0
- sockjs (npm): affected all versions; fixed in 0.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8823/ (Markdown: https://insights.sbomify.com/CVE-2020-8823/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8823
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8823
- OSV: https://osv.dev/vulnerability/CVE-2020-8823

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8823/
Summaries are generated and may contain mistakes; the official description above is the record.
