# CVE-2020-8867: Insufficient Session Expiration and TOCTOU Race Condition in OPC FOundation UA .Net Standard

> Remote attackers can cause a denial-of-service condition in OPC Foundation UA .NET Standard by exploiting a race condition in session handling without authentication.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-9q94-v7ch-mxqw

## What is CVE-2020-8867?

CVE-2020-8867 is a medium-severity vulnerability in OPC Foundation UA .NET Standard, published on 22 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This vulnerability allows remote attackers to create a denial-of-service condition on affected installations of OPC Foundation UA .NET Standard 1.04.358.30. Authentication is not required to exploit this vulnerability. The specific flaw exists within the handling of sessions. The issue results from the lack of proper locking when performing operations on an object. An attacker can leverage this vulnerability to create a denial-of-service condition against the application. Was ZDI-CAN-10295.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration), CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2020-8867?

2 open source packages ship an affected version, including OPCFoundation.NetStandard.Opc.Ua. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `OPCFoundation.NetStandard.Opc.Ua` | NuGet | All versions | 1.4.359.31 |
| `OPCFoundation.NetStandard.Opc.Ua` | NuGet | All versions | 1.4.359.31 |

Products: Opcfoundation Unified Architecture .Net-Standard.

## How do I fix CVE-2020-8867?

Upgrade OPCFoundation.NetStandard.Opc.Ua to 1.4.359.31 or later.

## Is CVE-2020-8867 being exploited?

There is no known exploitation of CVE-2020-8867 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8867 and fix it if it is affected.

What it is: CVE-2020-8867 is a medium-severity vulnerability in OPC Foundation UA .NET Standard, published on 22 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-8867 in the wild and no public exploit code.

Affected packages and fixed versions:
- OPCFoundation.NetStandard.Opc.Ua (NuGet): affected all versions; fixed in 1.4.359.31
- OPCFoundation.NetStandard.Opc.Ua (NuGet): affected all versions; fixed in 1.4.359.31

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8867/ (Markdown: https://insights.sbomify.com/CVE-2020-8867/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8867
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8867
- OSV: https://osv.dev/vulnerability/CVE-2020-8867

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8867/
Summaries are generated and may contain mistakes; the official description above is the record.
