# CVE-2020-8910: Auth Bypass in Google's Closure-Library

> An attacker can exploit a URL parsing flaw in the Google Closure Library to bypass security checks by returning incorrect authority information.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-vh5w-fg69-rc8m, UBUNTU-CVE-2020-8910

## What is CVE-2020-8910?

CVE-2020-8910 is a medium-severity authentication bypass vulnerability in Google Closure-Library, published on 26 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A URL parsing issue in goog.uri of the Google Closure Library versions up to and including v20200224 allows an attacker to send malicious URLs to be parsed by the library and return the wrong authority. Mitigation: update your library to version v20200315.

Weakness: CWE-625 (Permissive Regular Expression)

## Which versions are affected by CVE-2020-8910?

2 open source packages ship an affected version, including google-closure-library. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `google-closure-library` | npm | All versions | 20200315.0.0 |
| `google-closure-library` | npm | All versions | 20200315.0.0 |

Products: Google Closure Library.

## How do I fix CVE-2020-8910?

Upgrade google-closure-library to 20200315.0.0 or later.

## Is CVE-2020-8910 being exploited?

There is no known exploitation of CVE-2020-8910 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-8910 and fix it if it is affected.

What it is: CVE-2020-8910 is a medium-severity authentication bypass vulnerability in Google Closure-Library, published on 26 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-8910 in the wild and no public exploit code.

Affected packages and fixed versions:
- google-closure-library (npm): affected all versions; fixed in 20200315.0.0
- google-closure-library (npm): affected all versions; fixed in 20200315.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-8910/ (Markdown: https://insights.sbomify.com/CVE-2020-8910/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-8910
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-8910
- OSV: https://osv.dev/vulnerability/CVE-2020-8910

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-8910/
Summaries are generated and may contain mistakes; the official description above is the record.
