CVE-2020-8918 TPM 1.2 key authorization values are vulnerable to a TPM transport eavesdropper
An eavesdropper can recover TPM key authorization values due to improper initialization in the go-tpm library, exposing sensitive credentials.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-8918?
CVE-2020-8918 is a medium-severity vulnerability in google/go-tpm library, published on 11 Aug 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
An improperly initialized 'migrationAuth' value in Google's go-tpm TPM1.2 library versions prior to 0.3.0 can lead an eavesdropping attacker to discover the auth value for a key created with CreateWrapKey. An attacker listening in on the channel can collect both 'encUsageAuth' and 'encMigrationAuth', and then can calculate 'usageAuth ^ encMigrationAuth' as the 'migrationAuth' can be guessed for all keys created with CreateWrapKey. TPM2.0 is not impacted by this. We recommend updating your library to 0.3.0 or later, or, if you cannot update, to call CreateWrapKey with a random 20-byte value for 'migrationAuth'.
Weakness: CWE-665
Which versions are affected by CVE-2020-8918?
3 open source packages ship an affected version, including github.com/google/go-tpm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/google/go-tpm Go | All versions | 0.3.0 |
github.com/google/go-tpm Go | All versions | 0.3.0 |
github.com/google/go-tpm Go | All versions | 0.3.0 |
Products include Google Go-Tpm.
How do I fix CVE-2020-8918?
Upgrade github.com/google/go-tpm to 0.3.0 or later.
Is CVE-2020-8918 being exploited?
There is no known exploitation of CVE-2020-8918 in the wild and no public exploit code.
Sources
Also known as GHSA-5x29-3hr9-6wpw, GO-2021-0095.