CVE-2020-8920 Overoptimization leads to private information leak in Gerrit
An overoptimization bug in Gerrit skips access checks, allowing attackers to read private user account information.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-8920?
CVE-2020-8920 is a low-severity missing authorization vulnerability in Gerrit, published on 10 Dec 2020. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
An information leak vulnerability exists in Gerrit versions prior to 2.14.22, 2.15.21, 2.16.25, 3.0.15, 3.1.10, 3.2.5 where an overoptimization with the FilteredRepository wrapper skips the verification of access on All-Users repositories, allowing an attacker to get read access to all users' personal information associated with their accounts.
Weakness: CWE-285
Which versions are affected by CVE-2020-8920?
12 open source packages ship an affected version, including com.google.gerrit:gerrit-plugin-api. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
com.google.gerrit:gerrit-plugin-api Maven | All versions | 2.14.22 |
com.google.gerrit:gerrit-plugin-api Maven | All versions | 2.14.22 |
com.google.gerrit:gerrit-plugin-api Maven | From 2.15.0 | 2.15.21 |
com.google.gerrit:gerrit-plugin-api Maven | From 2.15.0 | 2.15.21 |
com.google.gerrit:gerrit-plugin-api Maven | From 2.16.0 | 2.16.25 |
com.google.gerrit:gerrit-plugin-api Maven | From 2.16.0 | 2.16.25 |
6 more packages
com.google.gerrit:gerrit-plugin-api Maven | From 3.0.0 | 3.0.15 |
com.google.gerrit:gerrit-plugin-api Maven | From 3.0.0 | 3.0.15 |
com.google.gerrit:gerrit-plugin-api Maven | From 3.1.0 | 3.1.10 |
com.google.gerrit:gerrit-plugin-api Maven | From 3.1.0 | 3.1.10 |
com.google.gerrit:gerrit-plugin-api Maven | From 3.2.0 | 3.2.5 |
com.google.gerrit:gerrit-plugin-api Maven | From 3.2.0 | 3.2.5 |
Products include Google Gerrit.
How do I fix CVE-2020-8920?
Upgrade com.google.gerrit:gerrit-plugin-api to a fixed version for your release line: 2.14.22, 2.15.21, 2.16.25 or 3.0.15.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2020-8920 being exploited?
There is no known exploitation of CVE-2020-8920 in the wild and no public exploit code.
Other vulnerabilities in Gerrit
Sources
Also known as GHSA-g5q2-cxgq-h2rw.