# CVE-2020-9280: SilverStripe Folders migrated from 3.x may be unsafe to upload to

> SilverStripe CMS may store uploaded files in unprotected folders, allowing unauthorized access to sensitive data if specific migration and module conditions are met.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-silverstripe-2020-9280, GHSA-592m-4533-rxq9

## What is CVE-2020-9280?

CVE-2020-9280 is a high-severity vulnerability in Silverstripe Silverstripe, published on 15 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In SilverStripe through 4.5, files uploaded via Forms to folders migrated from Silverstripe CMS 3.x may be put to the default "/Uploads" folder instead. This affects installations which allowed upload folder protection via the optional silverstripe/secureassets module under 3.x. This module is installed and enabled by default on the Common Web Platform (CWP). The vulnerability only affects files uploaded after an upgrade to 4.x.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2020-9280?

9 open source packages ship an affected version, including silverstripe/assets, silverstripe and silverstripe/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/assets` | Packagist | From 1.0.0 | 1.4.7 |
| `silverstripe/assets` | Packagist | From 1.0.0 | 1.4.7 |
| `silverstripe/assets` | Packagist | From 1.5.0 | 1.5.2 |
| `silverstripe/assets` | Packagist | From 1.5.0 | 1.5.2 |
| `silverstripe` | Bitnami | From 4.0.0 | 4.5.0 |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.4.6 |
| `silverstripe/framework` | Packagist | From 4.0.0 | 4.4.6 |
| `silverstripe/userforms` | Packagist | From 5.0.0 | 5.4.2 |
| `silverstripe/userforms` | Packagist | From 5.0.0 | 5.4.2 |

Products: Silverstripe Silverstripe.

## How do I fix CVE-2020-9280?

Upgrade silverstripe/assets to a fixed version for your release line: 1.4.7 or 1.5.2.

## Is CVE-2020-9280 being exploited?

There is no known exploitation of CVE-2020-9280 in the wild and no public exploit code.

## Other vulnerabilities in Silverstripe Silverstripe

- [CVE-2007-2321](https://insights.sbomify.com/CVE-2007-2321/): Other in n/a (critical 10.0)
- [CVE-2019-12204](https://insights.sbomify.com/CVE-2019-12204/): Missing warning can lead to unauthenticated admin access in SilverStripe (critical 9.8)
- [CVE-2019-5715](https://insights.sbomify.com/CVE-2019-5715/): Silverstripe Framework SQLi Vulnerability (critical 9.8)
- [CVE-2019-12437](https://insights.sbomify.com/CVE-2019-12437/): Silverstripe CSRF Protection Bypass via GraphQL (high 8.8)
- [CVE-2020-6164](https://insights.sbomify.com/CVE-2020-6164/): Silverstripe CMS information disclosure (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-9280 and fix it if it is affected.

What it is: CVE-2020-9280 is a high-severity vulnerability in Silverstripe Silverstripe, published on 15 Apr 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-9280 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/assets (Packagist): affected from 1.0.0; fixed in 1.4.7
- silverstripe/assets (Packagist): affected from 1.0.0; fixed in 1.4.7
- silverstripe/assets (Packagist): affected from 1.5.0; fixed in 1.5.2
- silverstripe/assets (Packagist): affected from 1.5.0; fixed in 1.5.2
- silverstripe (Bitnami): affected from 4.0.0; fixed in 4.5.0
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.4.6
- silverstripe/framework (Packagist): affected from 4.0.0; fixed in 4.4.6
- silverstripe/userforms (Packagist): affected from 5.0.0; fixed in 5.4.2
- silverstripe/userforms (Packagist): affected from 5.0.0; fixed in 5.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-9280/ (Markdown: https://insights.sbomify.com/CVE-2020-9280/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-9280
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-9280
- OSV: https://osv.dev/vulnerability/CVE-2020-9280

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-9280/
Summaries are generated and may contain mistakes; the official description above is the record.
