# CVE-2020-9281: CKEditor 4.0 vulnerability in the HTML Data Processor

> Remote attackers can inject arbitrary web script via crafted protected comments in CKEditor's HTML Data Processor, potentially compromising user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-drupal-2020-9281, GHSA-vcjf-mgcg-jxjq, UBUNTU-CVE-2020-9281

## What is CVE-2020-9281?

CVE-2020-9281 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 7 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site scripting (XSS) vulnerability in the HTML Data Processor for CKEditor 4.0 before 4.14 allows remote attackers to inject arbitrary web script through a crafted "protected" comment (with the cke_protected syntax).

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-9281?

3 open source packages ship an affected version, including drupal and ckeditor4. It affects 11 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal` | Bitnami | From 8.7.0 | 8.7.12, 8.8.4 |
| `ckeditor4` | npm | All versions | 4.14.0 |
| `ckeditor4` | npm | All versions | 4.14.0 |

Products: Ckeditor Ckeditor, Drupal Drupal, Fedoraproject Fedora, Oracle Agile Product Lifecycle Management, Oracle Application Express, Oracle Banking Enterprise Default Management, Oracle Banking Enterprise Default Managment, Oracle Jd Edwards Enterpriseone Tools, Oracle Peoplesoft Enterprise Peopletools, Oracle Siebel Apps - Customer Order Management, Oracle Webcenter Portal.

## How do I fix CVE-2020-9281?

Upgrade drupal to a fixed version for your release line: 8.7.12 or 8.8.4.

## Is CVE-2020-9281 being exploited?

There is no known exploitation of CVE-2020-9281 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2023-31541](https://insights.sbomify.com/CVE-2023-31541/): File upload in n/a (critical 9.8)
- [CVE-2021-41164](https://insights.sbomify.com/CVE-2021-41164/): Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML (high 8.2)
- [CVE-2021-41165](https://insights.sbomify.com/CVE-2021-41165/): HTML comments vulnerability allowing to execute JavaScript code (high 8.2)
- [CVE-2021-32808](https://insights.sbomify.com/CVE-2021-32808/): Cross-site scripting in ckeditor via abuse of undo functionality (high 7.6)
- [CVE-2011-4972](https://insights.sbomify.com/CVE-2011-4972/): Missing authorization in CKEditor Drupal module (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-9281 and fix it if it is affected.

What it is: CVE-2020-9281 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 7 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-9281 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal (Bitnami): affected from 8.7.0; fixed in 8.7.12, 8.8.4
- ckeditor4 (npm): affected all versions; fixed in 4.14.0
- ckeditor4 (npm): affected all versions; fixed in 4.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-9281/ (Markdown: https://insights.sbomify.com/CVE-2020-9281/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-9281
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-9281
- OSV: https://osv.dev/vulnerability/CVE-2020-9281

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-9281/
Summaries are generated and may contain mistakes; the official description above is the record.
