# CVE-2020-9311: Silverstripe CMS XSS Vulnerability

> Authenticated users can inject malicious scripts via profile information, leading to XSS attacks against other users in SilverStripe CMS.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-silverstripe-2020-9311, GHSA-2pw2-qpcp-m47x

## What is CVE-2020-9311?

CVE-2020-9311 is a medium-severity cross-site scripting vulnerability in Silverstripe Silverstripe, published on 15 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In SilverStripe through 4.5, malicious users with a valid Silverstripe CMS login (usually CMS access) can craft profile information which can lead to XSS for other users through specially crafted login form URLs.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-9311?

5 open source packages ship an affected version, including silverstripe/cms, silverstripe and silverstripe/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/cms` | Packagist | All versions to 4.5.0 | None |
| `silverstripe/cms` | Packagist | All versions to 4.5.0 | None |
| `silverstripe` | Bitnami | From 3.0.0 | 3.7.5 |
| `silverstripe/framework` | Packagist | From 3.0.0 | 3.7.5 |
| `silverstripe/framework` | Packagist | From 3.0.0 | 3.7.5 |

Products: Silverstripe Silverstripe.

## How do I fix CVE-2020-9311?

Upgrade to a fixed version.

## Is CVE-2020-9311 being exploited?

There is no known exploitation of CVE-2020-9311 in the wild and no public exploit code.

## Other vulnerabilities in Silverstripe Silverstripe

- [CVE-2007-2321](https://insights.sbomify.com/CVE-2007-2321/): Other in n/a (critical 10.0)
- [CVE-2019-12204](https://insights.sbomify.com/CVE-2019-12204/): Missing warning can lead to unauthenticated admin access in SilverStripe (critical 9.8)
- [CVE-2019-5715](https://insights.sbomify.com/CVE-2019-5715/): Silverstripe Framework SQLi Vulnerability (critical 9.8)
- [CVE-2019-12437](https://insights.sbomify.com/CVE-2019-12437/): Silverstripe CSRF Protection Bypass via GraphQL (high 8.8)
- [CVE-2020-6164](https://insights.sbomify.com/CVE-2020-6164/): Silverstripe CMS information disclosure (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-9311 and fix it if it is affected.

What it is: CVE-2020-9311 is a medium-severity cross-site scripting vulnerability in Silverstripe Silverstripe, published on 15 Jul 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-9311 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/cms (Packagist): affected all versions up to 4.5.0; no fix listed
- silverstripe/cms (Packagist): affected all versions up to 4.5.0; no fix listed
- silverstripe (Bitnami): affected from 3.0.0; fixed in 3.7.5
- silverstripe/framework (Packagist): affected from 3.0.0; fixed in 3.7.5
- silverstripe/framework (Packagist): affected from 3.0.0; fixed in 3.7.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-9311/ (Markdown: https://insights.sbomify.com/CVE-2020-9311/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-9311
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-9311
- OSV: https://osv.dev/vulnerability/CVE-2020-9311

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-9311/
Summaries are generated and may contain mistakes; the official description above is the record.
