# CVE-2020-9318: SQL injection in n/a

> Administrative users can execute SQL injection via SNMP alert settings in Red Gate SQL Monitor, potentially leading to code execution or data access.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Feb 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-pw4f-4jh7-3j6p

## What is CVE-2020-9318?

CVE-2020-9318 is a high-severity SQL injection vulnerability in n/a, published on 20 Feb 2020. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Red Gate SQL Monitor 9.0.13 through 9.2.14 allows an administrative user to perform a SQL injection attack by configuring the SNMP alert settings in the UI. This is fixed in 9.2.15.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2020-9318?

It affects 1 product.


Products: Red-Gate Sql Monitor.

## How do I fix CVE-2020-9318?

No fix has been published for CVE-2020-9318 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-9318 being exploited?

There is no known exploitation of CVE-2020-9318 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2015-9098](https://insights.sbomify.com/CVE-2015-9098/): SQL injection in n/a (critical 9.8)
- [CVE-2022-47542](https://insights.sbomify.com/CVE-2022-47542/): Privilege escalation in n/a (high 8.8)
- [CVE-2022-47870](https://insights.sbomify.com/CVE-2022-47870/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2020-15526](https://insights.sbomify.com/CVE-2020-15526/): Security feature bypass in n/a (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-9318 and fix it if it is affected.

What it is: CVE-2020-9318 is a high-severity SQL injection vulnerability in n/a, published on 20 Feb 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-9318 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-9318/ (Markdown: https://insights.sbomify.com/CVE-2020-9318/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-9318
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-9318
- OSV: https://osv.dev/vulnerability/CVE-2020-9318

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-9318/
Summaries are generated and may contain mistakes; the official description above is the record.
