# CVE-2020-9327: Null dereference in n/a

> Attackers can trigger a segmentation fault in SQLite via generated column optimizations, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Feb 2020
- **Updated:** 14 Oct 2026
- **Also known as:** BIT-sqlite-2020-9327, DEBIAN-CVE-2020-9327, GHSA-43wf-f579-3w62, UBUNTU-CVE-2020-9327

## What is CVE-2020-9327?

CVE-2020-9327 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 21 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In SQLite 3.31.1, isAuxiliaryVtabOperator allows attackers to trigger a NULL pointer dereference and segmentation fault because of generated column optimizations.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2020-9327?

1 open source package ship an affected version, including sqlite. It affects 11 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sqlite` | Bitnami | From 3.31.1 | 3.31.2 |

Products: Canonical Ubuntu Linux, Netapp Cloud Backup, Oracle Communications Messaging Server, Oracle Communications Network Charging and Control, Oracle Enterprise Manager Ops Center, Oracle Hyperion Infrastructure Technology, Oracle Mysql Workbench, Oracle Outside in Technology, Oracle Zfs Storage Appliance Kit, Siemens Sinec Infrastructure Network Services, Sqlite Sqlite.

## How do I fix CVE-2020-9327?

Upgrade sqlite to 3.31.2 or later.

## Is CVE-2020-9327 being exploited?

There is no known exploitation of CVE-2020-9327 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-9327 and fix it if it is affected.

What it is: CVE-2020-9327 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 21 Feb 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-9327 in the wild and no public exploit code.

Affected packages and fixed versions:
- sqlite (Bitnami): affected from 3.31.1; fixed in 3.31.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-9327/ (Markdown: https://insights.sbomify.com/CVE-2020-9327/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-9327
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-9327
- OSV: https://osv.dev/vulnerability/CVE-2020-9327

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-9327/
Summaries are generated and may contain mistakes; the official description above is the record.
