# CVE-2020-9402: SQL injection in Django

> Attackers can inject malicious SQL via crafted tolerance parameters in GIS functions on Oracle databases, requiring specific database configuration.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-9402, BIT-django-2020-9402, DEBIAN-CVE-2020-9402, DLA-3024-1, GHSA-3gh2-xw74-jmcw, PYSEC-2020-36, UBUNTU-CVE-2020-9402, USN-4296-1

## What is CVE-2020-9402?

CVE-2020-9402 is a high-severity SQL injection vulnerability in Canonical Ubuntu Linux, published on 5 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Django 1.11 before 1.11.29, 2.2 before 2.2.11, and 3.0 before 3.0.4 allows SQL Injection if untrusted data is used as a tolerance parameter in GIS functions and aggregates on Oracle. By passing a suitably crafted tolerance to GIS functions and aggregates on Oracle, it was possible to break escaping and inject malicious SQL.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2020-9402?

8 open source packages ship an affected version, including django and Django. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 1.11.0 | 1.11.29, 2.2.11, 3.0.4 |
| `django` | PyPI | From 1.11 | 1.11.29, 2.2.11, 3.0.4 |
| `django` | PyPI | From 1.11 | 1.11.29 |
| `django` | PyPI | From 2.2 | 2.2.11 |
| `django` | PyPI | From 3.0 | 3.0.4 |
| `Django` | PyPI | From 1.11 | 1.11.29 |
| `Django` | PyPI | From 2.2 | 2.2.11 |
| `Django` | PyPI | From 3.0 | 3.0.4 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Djangoproject Django, Fedoraproject Fedora, Netapp Steelstore Cloud Integrated Storage.

## How do I fix CVE-2020-9402?

Upgrade django to a fixed version for your release line: 1.11.29, 2.2.11 or 3.0.4.

## Is CVE-2020-9402 being exploited?

There is no known exploitation of CVE-2020-9402 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-9402 and fix it if it is affected.

What it is: CVE-2020-9402 is a high-severity SQL injection vulnerability in Canonical Ubuntu Linux, published on 5 Mar 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-9402 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 1.11.0; fixed in 1.11.29, 2.2.11, 3.0.4
- django (PyPI): affected from 1.11; fixed in 1.11.29, 2.2.11, 3.0.4
- django (PyPI): affected from 1.11; fixed in 1.11.29
- django (PyPI): affected from 2.2; fixed in 2.2.11
- django (PyPI): affected from 3.0; fixed in 3.0.4
- Django (PyPI): affected from 1.11; fixed in 1.11.29
- Django (PyPI): affected from 2.2; fixed in 2.2.11
- Django (PyPI): affected from 3.0; fixed in 3.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-9402/ (Markdown: https://insights.sbomify.com/CVE-2020-9402/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-9402
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-9402
- OSV: https://osv.dev/vulnerability/CVE-2020-9402

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-9402/
Summaries are generated and may contain mistakes; the official description above is the record.
