# CVE-2020-9480: Improper Authentication in Apache Spark

> Attackers can bypass authentication in Apache Spark standalone mode to execute arbitrary shell commands on the host machine.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-spark-2020-9480, GHSA-wgx7-jwwm-cgjv, PYSEC-2020-95

## What is CVE-2020-9480?

CVE-2020-9480 is a critical authentication bypass vulnerability in Oracle Business Intelligence, published on 23 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache Spark 2.4.5 and earlier, a standalone resource manager's master may be configured to require authentication (spark.authenticate) via a shared secret. When enabled, however, a specially-crafted RPC to the master can succeed in starting an application's resources on the Spark cluster, even without the shared key. This can be leveraged to execute shell commands on the host machine. This does not affect Spark clusters using other resource managers (YARN, Mesos, etc).

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2020-9480?

6 open source packages ship an affected version, including pyspark, spark and org.apache.spark:spark-parent_2.11. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyspark` | PyPI | All versions | 2.4.6 |
| `pyspark` | PyPI | All versions | 2.4.6 |
| `pyspark` | PyPI | All versions | 2.4.6 |
| `spark` | Bitnami | All versions | 2.4.6 |
| `org.apache.spark:spark-parent_2.11` | Maven | All versions | 2.4.6 |
| `org.apache.spark:spark-parent_2.11` | Maven | All versions | 2.4.6 |

Products: Apache Spark, Oracle Business Intelligence.

## How do I fix CVE-2020-9480?

Upgrade pyspark to 2.4.6 or later.

## Is CVE-2020-9480 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-9480 exists.

Public exploit code:

- https://github.com/XiaoShaYu617/CVE-2020-9480 (github_poc): https://github.com/XiaoShaYu617/CVE-2020-9480
- Apache Spark - Authentication Bypass (nuclei): http/cves/2020/CVE-2020-9480.yaml

## Other vulnerabilities in Oracle Business Intelligence

- [CVE-2022-33891](https://insights.sbomify.com/CVE-2022-33891/): Apache Spark Command Injection (high 8.8, exploited in the wild)
- [CVE-2018-17190](https://insights.sbomify.com/CVE-2018-17190/): Remote Code Execution in spark-core (critical 9.8)
- [CVE-2019-20445](https://insights.sbomify.com/CVE-2019-20445/): HTTP Request Smuggling in Netty (critical 9.1)
- [CVE-2025-54920](https://insights.sbomify.com/CVE-2025-54920/): Apache Spark: Spark History Server Code Execution Vulnerability (high 8.8)
- [CVE-2023-32007](https://insights.sbomify.com/CVE-2023-32007/): Apache Spark: Shell command injection via Spark UI (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-9480 and fix it if it is affected.

What it is: CVE-2020-9480 is a critical authentication bypass vulnerability in Oracle Business Intelligence, published on 23 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-9480 exists.

Affected packages and fixed versions:
- pyspark (PyPI): affected all versions; fixed in 2.4.6
- pyspark (PyPI): affected all versions; fixed in 2.4.6
- pyspark (PyPI): affected all versions; fixed in 2.4.6
- spark (Bitnami): affected all versions; fixed in 2.4.6
- org.apache.spark:spark-parent_2.11 (Maven): affected all versions; fixed in 2.4.6
- org.apache.spark:spark-parent_2.11 (Maven): affected all versions; fixed in 2.4.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-9480/ (Markdown: https://insights.sbomify.com/CVE-2020-9480/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-9480
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-9480
- OSV: https://osv.dev/vulnerability/CVE-2020-9480

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-9480/
Summaries are generated and may contain mistakes; the official description above is the record.
