CVE-2020-9485 Stored XSS in Apache Airflow

Medium 6.1 Published Updated

Attackers can inject malicious scripts into Apache Airflow's classic UI chart pages, potentially compromising user sessions and data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-9485?

CVE-2020-9485 is a medium-severity cross-site scripting vulnerability in Apache Airflow, published on 16 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

An issue was found in Apache Airflow versions 1.10.10 and below. A stored XSS vulnerability was discovered in the Chart pages of the the "classic" UI.

Weakness: CWE-79

Which versions are affected by CVE-2020-9485?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIAll versions1.10.11
apache-airflow PyPIAll versions1.10.11
apache-airflow PyPIAll versions1.10.11rc1
airflow BitnamiAll versions1.10.11

Products include Apache Airflow.

How do I fix CVE-2020-9485?

Upgrade apache-airflow to a fixed version for your release line: 1.10.11 or 1.10.11rc1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-9485 being exploited?

There is no known exploitation of CVE-2020-9485 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2020-9485, GHSA-j38c-25fj-mr84, PYSEC-2020-23.

Is CVE-2020-9485 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free