# CVE-2020-9491: Inadequate Encryption Strength in Apache NiFi

> Apache NiFi allows weak TLS versions for internal cluster communications, potentially enabling man-in-the-middle attacks against replicated data and queues.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-nifi-2020-9491, GHSA-rfmp-jvr7-hx78

## What is CVE-2020-9491?

CVE-2020-9491 is a high-severity vulnerability in Apache Nifi, published on 1 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Apache NiFi 1.2.0 to 1.11.4, the NiFi UI and API were protected by mandating TLS v1.2, as well as listening connections established by processors like ListenHTTP, HandleHttpRequest, etc. However intracluster communication such as cluster request replication, Site-to-Site, and load balanced queues continued to support TLS v1.0 or v1.1.

Weakness: CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2020-9491?

3 open source packages ship an affected version, including org.apache.nifi:nifi and nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi` | Maven | From 1.2.0 | 1.12.0-RC1 |
| `org.apache.nifi:nifi` | Maven | From 1.2.0 | 1.12.0-RC1 |
| `nifi` | Bitnami | From 1.0.0 to 1.11.4 | None |

Products: Apache Nifi.

## How do I fix CVE-2020-9491?

Upgrade org.apache.nifi:nifi to 1.12.0-RC1 or later.

## Is CVE-2020-9491 being exploited?

There is no known exploitation of CVE-2020-9491 in the wild and no public exploit code.

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-9491 and fix it if it is affected.

What it is: CVE-2020-9491 is a high-severity vulnerability in Apache Nifi, published on 1 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-9491 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.nifi:nifi (Maven): affected from 1.2.0; fixed in 1.12.0-RC1
- org.apache.nifi:nifi (Maven): affected from 1.2.0; fixed in 1.12.0-RC1
- nifi (Bitnami): affected from 1.0.0 up to 1.11.4; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-9491/ (Markdown: https://insights.sbomify.com/CVE-2020-9491/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-9491
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-9491
- OSV: https://osv.dev/vulnerability/CVE-2020-9491

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-9491/
Summaries are generated and may contain mistakes; the official description above is the record.
