# CVE-2020-9497: Information disclosure in Apache Guacamole

> An attacker controlling a malicious RDP server can leak memory contents from the Guacamole proxy process when a user connects.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-guacamole-2020-9497, BIT-guacamole-server-2020-9497, DEBIAN-CVE-2020-9497, GHSA-9q4f-696q-fjxm, UBUNTU-CVE-2020-9497

## What is CVE-2020-9497?

CVE-2020-9497 is a medium-severity vulnerability in Debian Debian Linux, published on 2 Jul 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Apache Guacamole 1.1.0 and older do not properly validate datareceived from RDP servers via static virtual channels. If a userconnects to a malicious or compromised RDP server, specially-craftedPDUs could result in disclosure of information within the memory ofthe guacd process handling the connection.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-9497?

2 open source packages ship an affected version, including guacamole and guacamole-server. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `guacamole` | Bitnami | All versions | 1.1.0 |
| `guacamole-server` | Bitnami | All versions | 1.1.0 |

Products: Apache Guacamole, Debian Debian Linux, Fedoraproject Fedora.

## How do I fix CVE-2020-9497?

Upgrade guacamole to 1.1.0 or later.

## Is CVE-2020-9497 being exploited?

There is no known exploitation of CVE-2020-9497 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2021-43999](https://insights.sbomify.com/CVE-2021-43999/): Improper validation of SAML responses (high 8.8)
- [CVE-2017-3158](https://insights.sbomify.com/CVE-2017-3158/): Apache Guacamole Race Condition vulnerability (high 8.1)
- [CVE-2023-43826](https://insights.sbomify.com/CVE-2023-43826/): Apache Guacamole: Integer overflow in handling of VNC image buffers (high 7.5)
- [CVE-2019-19603](https://insights.sbomify.com/CVE-2019-19603/): Null dereference in n/a (high 7.5)
- [CVE-2018-1340](https://insights.sbomify.com/CVE-2018-1340/): Missing Encryption of Sensitive Data in Apache Guacamole (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-9497 and fix it if it is affected.

What it is: CVE-2020-9497 is a medium-severity vulnerability in Debian Debian Linux, published on 2 Jul 2020. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-9497 in the wild and no public exploit code.

Affected packages and fixed versions:
- guacamole (Bitnami): affected all versions; fixed in 1.1.0
- guacamole-server (Bitnami): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-9497/ (Markdown: https://insights.sbomify.com/CVE-2020-9497/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-9497
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-9497
- OSV: https://osv.dev/vulnerability/CVE-2020-9497

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-9497/
Summaries are generated and may contain mistakes; the official description above is the record.
