# CVE-2020-9583: Magento command injection vulnerability

> Attackers can execute arbitrary code via command injection in Magento, requiring immediate patching for e-commerce security.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jun 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-magento-2020-9583, GHSA-c55h-7q4j-g6rq

## What is CVE-2020-9583?

CVE-2020-9583 is a critical command injection vulnerability in Magento Magento, published on 26 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Magento versions 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier have a command injection vulnerability. Successful exploitation could lead to arbitrary code execution.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2020-9583?

9 open source packages ship an affected version, including magento/community-edition, magento and magento/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | All versions to 2.2.11 | None |
| `magento/community-edition` | Packagist | All versions to 2.2.11 | None |
| `magento/community-edition` | Packagist | From 2.3.0 | 2.3.4-p2 |
| `magento/community-edition` | Packagist | From 2.3.0 | 2.3.4-p2 |
| `magento` | Bitnami | From 2.2.0 | 2.2.12, 2.3.5 |
| `magento/core` | Packagist | All versions | 1.9.4.5 |
| `magento/core` | Packagist | All versions | 1.9.4.5 |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |

Products: Magento Magento.

## How do I fix CVE-2020-9583?

Upgrade magento/community-edition to 2.3.4-p2 or later.

## Is CVE-2020-9583 being exploited?

There is no known exploitation of CVE-2020-9583 in the wild and no public exploit code.

## Other vulnerabilities in Magento Magento

- [CVE-2020-9664](https://insights.sbomify.com/CVE-2020-9664/): Magento php object injection vulnerability (critical 9.8)
- [CVE-2020-9576](https://insights.sbomify.com/CVE-2020-9576/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9578](https://insights.sbomify.com/CVE-2020-9578/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9579](https://insights.sbomify.com/CVE-2020-9579/): Magento Security mitigation bypass vulnerability (critical 9.8)
- [CVE-2020-9580](https://insights.sbomify.com/CVE-2020-9580/): Magento Security mitigation bypass vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-9583 and fix it if it is affected.

What it is: CVE-2020-9583 is a critical command injection vulnerability in Magento Magento, published on 26 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-9583 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected all versions up to 2.2.11; no fix listed
- magento/community-edition (Packagist): affected all versions up to 2.2.11; no fix listed
- magento/community-edition (Packagist): affected from 2.3.0; fixed in 2.3.4-p2
- magento/community-edition (Packagist): affected from 2.3.0; fixed in 2.3.4-p2
- magento (Bitnami): affected from 2.2.0; fixed in 2.2.12, 2.3.5
- magento/core (Packagist): affected all versions; fixed in 1.9.4.5
- magento/core (Packagist): affected all versions; fixed in 1.9.4.5
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-9583/ (Markdown: https://insights.sbomify.com/CVE-2020-9583/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-9583
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-9583
- OSV: https://osv.dev/vulnerability/CVE-2020-9583

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-9583/
Summaries are generated and may contain mistakes; the official description above is the record.
