{"answers":{"affected":"9 open source packages ship an affected version, including magento/community-edition, magento and magento/core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-9630 in the wild and no public exploit code.","fix":"Upgrade magento/community-edition to 2.3.4-p2 or later.","what":"CVE-2020-9630 is a critical vulnerability in Magento Magento, published on 26 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-9630 and fix it if it is affected.\n\nWhat it is: CVE-2020-9630 is a critical vulnerability in Magento Magento, published on 26 Jun 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-9630 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- magento/community-edition (Packagist): affected all versions up to 2.2.11; no fix listed\n- magento/community-edition (Packagist): affected all versions up to 2.2.11; no fix listed\n- magento/community-edition (Packagist): affected from 2.3.0; fixed in 2.3.4-p2\n- magento/community-edition (Packagist): affected from 2.3.0; fixed in 2.3.4-p2\n- magento (Bitnami): affected from 2.2.0; fixed in 2.2.12, 2.3.5\n- magento/core (Packagist): affected all versions; fixed in 1.9.4.5\n- magento/core (Packagist): affected all versions; fixed in 1.9.4.5\n- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed\n- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-9630/ (Markdown: https://insights.sbomify.com/CVE-2020-9630/index.md)","id":"CVE-2020-9630","markdown":"https://insights.sbomify.com/CVE-2020-9630/index.md","name":"CVE-2020-9630","record":{"aliases":["BIT-magento-2020-9630","GHSA-5j4w-v87m-8r65"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Magento e-commerce platform","requires_auth":"none","summary":"Attackers can exploit a business logic error in Magento to escalate privileges, requiring administrators to upgrade to patched versions.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"adobe","cpe":[{"product":"magento","vendor":"magento"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"Magento versions 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier have a business logic error vulnerability. Successful exploitation could lead to privilege escalation.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Magento business logic error vulnerability","id":"CVE-2020-9630","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"magento:magento","products":["magento:magento"],"type":"business_logic","year":"2020"},"n_packages":9,"n_references":1,"next":{"headline":"Magento security mitigation bypass vulnerability","id":"CVE-2020-9631"},"packages":[{"ecosystem":"Bitnami","fixed":["2.2.12","2.3.5"],"introduced":["2.2.0","2.3.0"],"last_affected":[],"package":"magento","purl":"pkg:bitnami/magento","source":"BIT-magento-2020-9630"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["2.2.11"],"package":"magento/community-edition","purl":null,"source":"GHSA-5j4w-v87m-8r65"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["2.2.11"],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-5j4w-v87m-8r65"},{"ecosystem":"Packagist","fixed":["2.3.4-p2"],"introduced":["2.3.0"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-5j4w-v87m-8r65"},{"ecosystem":"Packagist","fixed":["2.3.4-p2"],"introduced":["2.3.0"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-5j4w-v87m-8r65"},{"ecosystem":"Packagist","fixed":["1.9.4.5"],"introduced":["0"],"last_affected":[],"package":"magento/core","purl":null,"source":"GHSA-5j4w-v87m-8r65"},{"ecosystem":"Packagist","fixed":["1.9.4.5"],"introduced":["0"],"last_affected":[],"package":"magento/core","purl":"pkg:composer/magento/core","source":"GHSA-5j4w-v87m-8r65"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["2.0.2"],"package":"magento/project-community-edition","purl":null,"source":"GHSA-5j4w-v87m-8r65"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["2.0.2"],"package":"magento/project-community-edition","purl":"pkg:composer/magento/project-community-edition","source":"GHSA-5j4w-v87m-8r65"}],"prev":{"headline":"Information disclosure in Adobe DNG Software Development Kit (SDK)","id":"CVE-2020-9629"},"products":["Magento"],"published":"2020-06-26","related":[{"cvss_score":9.8,"headline":"Magento php object injection vulnerability","id":"CVE-2020-9664","kev_date_added":null,"published":"2020-07-22"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9576","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9578","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9579","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9580","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9582","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9583","kev_date_added":null,"published":"2020-06-26"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Adobe"]},"summary":"Attackers can exploit a business logic error in Magento to escalate privileges, requiring administrators to upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2020-9630/"}